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Introduction 
This set of exercises is designed to provide basic instruction on how to configure SNAP and 
how to use many of the model editing capabilities in SNAP. The following topics are 
covered: 

• Editing an existing model in the Model Editor. 
• Creating new component in a model. 
• Connecting components using the connect tool. 
• Duplicating components using copy/paste. 
• Manipulating drawn components in a view. 

These exercises assume you have properly installed RELAP5-3D or RELAP5 3.3 executable 
to perform job submission and post processing. 

Please refer to your system administrator or the installation instructions located on the 
SNAP website (https://www.snaphome.com) if you have any questions concerning 
installation. 
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Exercise 1. Configuring SNAP 
The following exercise provides a set of instructions for configuring a new SNAP installation 
for the following exercises. The SNAP software suite was designed to work with a minimal 
amount of configuration; therefore, most options can be left at their default values. The 
following steps assume that SNAP has not been previously configured on the system and 
that all properties are at their default values. 

1. Open the Configuration Tool by selecting SNAP → Configuration Tool from the 
QuickStart menu. 

2. Select your jEdit installation folder by pressing the Select (S) button next to the jEdit 
Folder property. 

3. Navigate to and select your jEdit installation directory the press the Open button. 
4. If an error is reported, the system did not detect the jEdit executable jar file in the 

expected location. 

5. Expand the Applications node in the tree on the left. 

Note: The next steps set up the jEdit application for use with SNAP. If jEdit is not 
installed, skip to step 5. 

In the steps we will define applications to include in the local calculation server. 
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6. Right-click on the Applications node and select New from the pop-up menu.  
This will open the Create Application dialog shown below. 

 
7. Select RELAP53D from the list of applications and press the OK button. 

A new, unspecified RELAP5 3D application definition will be created for use in SNAP 
models. The application should be selected with its properties displayed on the 
right. If not, follow the next step. 

8. Select the Unspecified RELAP5-3D application in the Application List. 
9. Set the Name property to ‘RELAP53D” 
10. Enter a description for the RELAP5 3D by pressing the E button next to the 

Description property. 
11. Enter a description for the application definition and press the OK button. 

These descriptions are shown along with the Name and Type when selecting 
application definitions inside the Model Editor. This provides a way to distinguish 
between multiple application definitions defined on the calculation server. 

12. Press the S to the right of the Local Location property, located in the Application 
Locations attribute group. 

13. In the File Selector select a valid executable for RELAP5 3D and press the Select 
button. 

14. Save the configuration by either selecting File → Save All from the main menu or by 
pressing the Save button ( ) in the tool-bar. 

15. Exit the Configuration Tool.  
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Exercise 2. Editing an Existing Model 
This exercise is designed to familiarize the analyst with the basic editing capabilities of the 
SNAP Model Editor using the RELAP5 plug-in. The following steps act as a guide through 
editing an existing RELAP5-3D model in SNAP. This exercise will cover a series of important 
topics including creating new components, editing component attributes, basic undo/redo 
functionality, and engineering units. 

The exercise will take a simple stand pipe model, reduce the pipe length by half, and add a 
crossflow connected valve so that the resulting model appears as displayed below: 
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The first step is to open the ModelEditor application. Select the SNAP → Model Editor option 
from the QuickStart menu. This will open the Model Editor and display the welcome dialog 
shown below: 

 

1. Select the Import a New Model option.  
2. Select the RELAP5 option when asked for the file type, and press the OK button. 

This will open a customized file selection dialog that allows selecting an ASCII input file, 
specifying the code and version along with advanced options for handling attribute 
ownership and Unix substitution variables.   

3. Navigate to the Exercises directory included with this tutorial and select the 
BaseStandPipe.i input file.  

4. Set the Code to RELAP5-3D, and the Version to 4.5. 
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5. Press the Open button. 
6. When prompted with the Create Views dialog, deselect all options and press the OK 

button. 
7. Close the Import Report dialog by pressing the Close button. 

The Model Editor should now appear as a mostly empty dialog with the 
Navigator on the left side populated by the contents of the imported 
model.  

8. Press the Validation button ( ) in the main toolbar. 

This opens the Validation Display for the current model. This display 
shows the expected ASCII input that will be generated from the full 
model. 

9. Right-click the Hydraulic Components node in the Navigator 
and select the Create View menu item. 
10. Set the Pixels Per Meter to 100. 
11. Set the Width Scale Factor to 2.0 
12. Hold the Control key down and individual select the time 
dependent volumes, single junction and time dependent junction in 
the view. 
13. Right-Click and select the Drawn Orientation → Up menu 
item. 
14. Drag the components until they show they are lined  up 
vertically.  
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Note that the Right-click menu includes an Align menu group that will help line the 
selected components together. The view should be like the image to the right. 

 

15. Select the vertical pipe in the view, or in the Navigator. 
16. Open the Geometry editing dialog. 
17. Click the first cell under the Length column, then hold the Shift key down, and click 

on the Length table cell for hydraulic cell number 20. 

Notice that the selection in the display at the top of the dialog mirrors the selection in 
the table, identifying which cell in the component is selected.  

18. Type the text 0.3 and press the Enter key. 

This will edit all the cells at the same time. Notice that the Total volume and length fields 
automatically update to reflect the new hydraulic cell length. 

19. Undo the modifications made to Pipe 1's lengths by selecting the Undo Cell Geometry 
Edit option from the Model Editor's Edit menu. 

Modifications performed in the Model editor can easily be undone and redone. This will 
update the editor, 2D views, and validation display reflect the changes to the pipe. 

20. Select the Redo Cell Geometry Edit option from the Model Editor's Edit menu. 
21. Press the Close button to close the dialog 
22. Select the Validation Display, and scroll to the 0011301 record. 
23. Click the mouse on the value 10 below ‘mlf’, which is the mass flow for the internal 

junctions in the pipe.  

Notice the text field at the top of the validation display shows the context for the property 
selected in the ASCII view. This currently shows: Pipe 1 → Initial Conditions → Junction [19] 
→ Liquid Mass Flow. By clicking the E button to the left of the context text field, the Pipe will 
be selected in the Navigator, The Initial Conditions property will be selected, the Initial 
Conditions editing dialog will open and the Liquid Mass Flow for Junction 19 will be 
selected. 

The next steps will begin to edit the input file. The pipe will be modified to be 6’ 
long, and have its initial conditions set to:  

Pressure: 515.0 psi 
Temperature: 470.0 F 
Liquid Velocity: 0.88 f/s 
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24. Press the E button to the left of the context label. 
25. Select the Velocities radio button. 
26. Select all the table cells for liquid velocity. 
27. Enter a value of 0.88 ft/s. 

Notice that the Validation Display automatically updated to reflect the modifications made 
in the Initial Conditions dialog. This happens whenever a value is modified in a “non-
modal” dialog. Non-Modal dialogs do not prevent interacting with the rest of the 
application when it is open. Modal dialogs are typified by having an OK and Cancel button. 
Non-modal dialogs only have a Close button. 

28. Select the Cell Fluid tab in the dialog. 
29. Select all the cells in the Condition column and double click in the last cell selected.  
30. Press the S button to open the Select T-flag Option dialog. 
31. Select T-FLAG 3 and press the OK button. 
32. Set all the Pressure values to 515 psi. 
33. Press the Close button. 

34. Locate the Hydraulic Components → Valves category in the Navigator. 
35. Create a new valve by selecting New from the Valves right-click pop-up menu. 
36. Set the Valve Type to Servo Valve 
37. Open the Geometry property editing dialog. 
38. Set the Area to 0.05 
39. Set the Area Change to 1 Full Abrupt Area Change. 
40. Press the Close button. 
41. Select the Hydraulic Components View in the Views tab. 
42. Drag the valve off the Navigator into the view to the right of Pipe 1. 

43. Select the Connection tool ( ) in the View Toolbar. 
44. Click the mouse on the circle on the left side of the valve to begin building a 

connection. 
45. Click on the diamond on the right side of the next-to-last cell in Pipe 1 to build the 

connection. 

The cursor will change to a target when the connect tool is selected. When the cursor 
hovers over the connection point located at the inlet of the valve a set of cross-hairs will 
appear in the target indicating that a connection can be made from this point. 

In the next few steps, we will add a discharge valve and some interactive control 
system components to the model. 
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Clicking the left mouse button while the cursor is on a connection point will initiate a 
connection. A rubber band line is created from the connection point to the cursor. A filled 
blue circle will appear when the cursor hovers over a valid target connection point. 

Move the cursor to the target connection point and click the left mouse button to create a 
connection. 

46. When prompted, select Crossflow 2, Outlet (face6) for the target face of the 
connection. 

47. Press the OK button. 
48. Create a new Time Dependent Volume in the Navigator. 
49. Open the Geometry property editing dialog for the new TDV. 
50. Set the Length to 0.6 ft. 
51. Set the Area to 0.181 ft2. 
52. Press the Close button. 
53. Set the T Flag property to [2] P, SQ 
54. Open the Fluid Conditions editing dialog. 
55. Set the table to have two rows with the following values: 

Table Entry 
Number 

Search 
Variable 

Pressure 
(psi) 

Static  
Quiality 

1 0.0 500 1.0 
2 1.0e9 500 1.0 

56. Drag the TDV into the view to the right of Valve 6. 
57. Right click TDV 7 and set its orientation to Right 
58. Use the Connect Tool to connect the outlet of 

Valve 6 to the inlet of TDV 7. 

At this point, the view should resemble the image to 
the right. The next steps will create interactive 
controls to open the valve. 

59. In the View Toolbar, click the down arrow below 
the Select Tool to expand the drop down menu of 
available components.  

60. Select Control Systems → Interactive Variables. 

 
61. Then click below TDV 7 in the view to insert the new Interactive Variable. 
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62. Set the Name to valvepos. 
63. Use the Insert Tool process above to insert a Control Systems → Control Block to the 

right of the valvepos interactive variable. 
64. Set the Control Blocks properties to the following. 

Property Value 
Name valveCB 
Type Lag 
Scaling Factor 0.05 
Initial Value 0.0 
Limiter Control [3] Minimum and Maximum 
Minimum Value 0.0 
Maximum Value 0.05 
Lag Time 3.0 s 

65. Open the Input Connections property editing dialog. 
66. Double click in the Source column for row 1. 
67. Press the E button to open the Select Control Input dialog. 
68. Select Interactive Variable 802 valvepos. 
69. Press the OK button in the Select Control Input dialog. 
70. Press the OK button in the Define Input Sources dialog. 

Notice that the output handle from the valvepos interactive variable has connected to the 
v1 input of the Lag control block. Control connections are shown with a red dashed line by 
default. This can be configured under General Preferences. 

71. Select Valve 6 in either the Navigator or the 2D View. 
72. Set it’s Control Variable to CB 2 Lag 

73.  Right-click Pipe 1 in the 2D View or the Navigator. Select the Edit Heatstructures → New 
menu item. 

74. Set the following values in the Initialize Heat Structure dialog: 
Property Value 

Geometry [2] Cylindrical 
Surface Left 
Thickness 0.036 
Temperature 470 F 
Material Carbon Steel 
Radial Meshpoints 5 

In the next steps we will create a pipe wall heat structure around pipe 1. This heat 
structure will have an inner diameter of 5.76in, and outer diameter of 6.625in.  A 
heat source will be applied through another interactive control to represent an 
electric heater around the pipe from 1.2ft to 6ft 
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75. Press the OK button. 

Notice that the pipe’s color has changed to red. This indicates a hydraulic component with 
one or more attached heat structures. 

76. Set the Left Boundary to 0.24 to clean up the round off from the volume area 
calculation. 

77. Below the valvepos interactive control use the Insert tool to add another Interactive 
Variable.  

78. Set the following properties on the new interactive variable. 
Property Value 

Name power 
Initial Value 1.0e4 
Feedback 
Variable 

cntrlvar-3 

79. Use the insert tool to create a new control block to the right of the new interactive 
variable. 

80. Set the following properties on the new control block. 
Property Value 

Name powerCB 
Type Lag 
Initial Value 1.0e4 
Lag Time 3.0 
Input Connections Interactive 

Variable 803 
81. Select Heat Structure 10 in the Navigator. 
82. Open the Axial Cells / BCs editing dialog in the Navigator. 
83. Use Shift Click to select Cells 5-20 in the Cell/Source Data column. 
84. Set the Source Type to Control Variable 
85. Set the Source Control to Control Block 3 (powerCB). 

This completes the first exercise. This model is in a runnable state, and can be submitted 
to a RELAP5-3D without error. The next exercise continues to modify the model. 
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Exercise 3. Working with Model Views. 
This exercise is designed to build upon the model created in Exercise 2 and continue 
introducing model building elements of SNAP. This exercise will cover topics including 
copying and pasting components, creating small control networks and engineering units. 

The exercise will take a simple stand pipe model, duplicate the pipe, and insert the 
duplicated component between the existing pipe and the outlet. The resulting system will 
match the system displayed below: 
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1. If you do not have the model from Exercise 2 open, open the file 
Exercises/Exercise2.med. 

2. Select Pipe 1 in the Navigator. 
3. Right-click the pipe and select the Copy menu item. 
4. Right-click the Pipes category node in the Navigator and 

select the Paste Special menu item. 
5. Select the Offset Component Number By radio button. 
6. Set the Offset to 1. 

The paste special dialog allows a user to create multiple 
copies of the same component starting at a specific offset 
with a specific number increment. Components may be 
copied with the same model, or into separate models open 
in the same instance of the Model Editor. 

7. Press the OK button. 
8. Select The Hydraulic Components View. 
9. Expand the Canvas Size by 1000 Pixels in each direction if they are currently less 

than 1000. 
10. Select the Inlet connection for TDJ 4, and Right-Click the Junction. 
11. Select the Disconnect menu item. 

12. Use the Select Tool ( ) to drag a box around all the components except TDJ4 and 
TDV5. 

13. Drag the selected components down a bit more than the length of pipe 1. 
14. Drag Pipe 8 into the view, below TDJ 4, and above Pipe 1 
15. Use the connect tool to connect the Inlet of TDJ 4 and the outlet of Pipe 8. 
16. In the 2D view right-click TDJ 4 and select the Copy menu item. 
17. Right-click next to TDJ 4 and select the Paste Special menu item. 
18. Press the OK button. 
19. Drag TDJ 9 down to in between Pipe 1 and 9. 
20. Use the Connect Tool to connect the outlet of TDJ9 to the inlet of Pipe 8, and the 

inlet of TDJ9 to the outlet of Pipe 1. 
21. Right-Click the Heat Structures node in the Navigator and select the New menu 

item. 
22. Set the contents of the Initialize Heat Structure to match the following: 

Property Value 
Geometry [2] Cylindrical 
Axial Length 6.0 ft. 
Thickness 0.036 ft 
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Inner Radius 0.24 ft 
Temperature 470 F 
Material Carbon Steel 
Axial Cells 20 
Radial Meshpoints 5 

23. Press the OK button. 
24. Open the Geometry editing dialog. 
25. Set the Relative Power values to 1.0. 
26. Press the OK button. 
27. Open the Axial Cells / BCs editing dialog 
28. Select all the cells from the Inner Surface Boundary Conditions column of the table. 
29. Set the Boundary Type to [1NN] 

Convective. 
30. Set the Boundary Connection to 

Hydraulic Volume. 
31. Open the Cell editing dialog. 
32. Set the Hydraulic Component to Pipe 8 
33. Press the OK button. 
34. Expand the [1CCCGX00] Additional 

Boundary Data attribute group. 
35. Set the Heated Length For. And Rev. 

properties to 100.0 ft.  
36. Select Cells 1-16 in the Cell/Source Data 

column 
37. Set the Source Type to [>10000] Control 

Variable 
38. Set the Source Control to powerCB. 
39. Set the Source Multiplier to 1.0. 
40. Press the OK button. 
41. Press the Check Model ( ) button to make sure there are currently no errors in the 

model. 

42. Use the Insert tool to create a new Control Block in an empty space in the view. 
43. Set the Name deltaP. 
44. Open the Input Connections editing dialog. 

In the next steps a control block summer will be created to determine the pressure 
drop across the two pipes. Two signal variables will be created signifying the 
pressures at opposite ends of the pipes. 
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45. Press the Add button. 
46. Press the Create button in the Select Control Input dialog. 
47. Click on Volumetric under Category and scroll down in Type until P - Volume 

Pressure is visible. 
48. Select P – Volume Pressure for the Type. 
49. In the Creation Criteria set the Hydraulic to Pipe 8 and set the Starting volume to 20. 

The Ending Volume will automatically adjust to 20. The ending volume must be greater 
than or equal to the starting volume index.  

50. Press the OK button in the Create a Signal Variable(s) dialog. 
51. Press the OK button in the Select Control Input dialog. 
52. Press the Add button again, followed by the Create button. 
53. Again, select Volumetric, and Volumetric Pressure. 
54. This time set the Hydraulic to set the Hydraulic to Pipe 1.  Leave the Starting and 

Ending Volumes at 1 and press the OK button. 

The Ending Volume will automatically adjust to 20. The ending volume must be greater 
than or equal to the starting volume index.  

55. Press the OK button to create the new signal variable, then press the OK button in 
the Select Control Input dialog. 

56. Set the Scale for input 2 to -1.0. 

 

57. The Define Input Sources dialog should match the image to the above. 
58. Press the OK button in the Define Input Sources Dialog. 
59. Expand the Control Systems → Signal Variables → 

Volumetric Signals tab in the Navigator. 
60. Drag the two Pressure signals to the left of the 

Summer Block. 

The small control network should match the image to the 
right.  
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61. To verify that the equation matches what we expect, right-click Sum 4 in the view 
and select the Show Equation menu. 

The equation should match the image to the right. 
If it doesn’t edit the input connections as 
described above. This summary works for all 
control block types. 

62. Use the Insert Tool to insert a Rectangle Annotation that surrounds the new control 
network.  

Notice that the new rectangle is on top of the components. Views have a Z-Order that 
controls  

63. Right-click on the rectangle and select the To Back menu item. 
64. Use the Insert tool to create a Text Annotation at the top of the rectangle. 
65. Set the Text to “Pipe Pressure Drop” 
66. Set the Font to Bold. 
67. Use the Control key and the Select tool to select both the rectangle and the text 

annotation. 
68. Right-click on the Rectangle and select the Align Select the Align Center horizontally 

menu item. 
69. Use the Select Tool to draw a selection box around the Rectangle annotation. 
70. Right-click in the Rectangle and select the Group menu item. 
71. Set the Insert tool to Annotations → Line Annotation. 
72. Click the Insert tool to the right of the 5th cell of Pipe 1. 
73. Double-Click to the right of the last cell of Pipe 1.  

The line annotation tool allows creating many line segments. The points between line 
segments can be individually moved, and line segments may be identified as curved. 
For right now we’re just creating simple straight lines. 

74. Set the following properties in the Line Annotation. 
Property Value 

Color 255, 0, 0 
First Arrow Head None 
Second Arrow Head None 

 

The next steps will add drawn annotations to the 2D view to help visually organize the 
components and provide additional information about the model.  
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75. Right-click the Line Annotation and select Copy. 
76. Right-click the View and select Paste Special. 
77. Select the Paste Mulitple Copies Radio button. 
78. Set the Number of Copies to 3. 
79. Press the OK button. 
80. Drag the pasted lines to the left and right of the heated sections of the pipes. 

81. Create a new View in the Navigator. 
82. Right-click on the View. 
83. Select the Tools → Import View Template menu item. 
84. Select the Exercise3Template.mvt included with these exercises. 
85. Press the Open button. 
86. Right-click on the View and select the Tools → Show All Connections menu item. 

Once you have a view laid out how you like it, you can save a view template to easily 
recreate that view. This will allow you to rebuild views from imported models, or to 
migrate views between similar models. Note that model components are identified 
by unique identifier, which for RELAP usually means Type and Number. These next 
steps will illustrate creating a view from a template. 
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This completes this exercise. The components should match the below image. You can 
leave this model open for the next exercise. 

Exercise 4. Introduction to Job Streams 
This exercise introduces the basics of building a Job Stream in the SNAP Model Editor. A 
stream consisting of a single RELAP5-3D step will be submitted to the local Calculation 
Server. Afterward, the stream will be monitored from the SNAP Job Status application, and 
the task output examined. 

The following steps set up a runs folder on the Local Calculation Server. This is the 
location in which streams will be run through the exercise. If the SNAP configuration for the 
Local Calculation Server already contains a suitable submit location, skip the next six 
steps and use this folder whenever the exercise refers to the runs directory. 
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1. Open Job Status. On Windows, select from the Start menu: All Programs → SNAP → 
Job Status. 

2. Press the Connect to Local button.  
3. At the No Root Folders prompt, press Yes.  

A file browser will appear. This is used to select a location on the server where streams 
can execute.  

4. In the file browser, navigate to a suitable run directory or create one. Press the 
Mount button once the folder is selected. 

5. A prompt will appear asking for the name of the new mount point. 
6. Enter the name “runs” for the folder and press the OK button. 

The runs folder will appear under Local 

7. Close Job Status 

8. Open the Model Editor if it isn’t open from Exercise 3. On Windows, select from the 
Start menu: All Programs → SNAP → Model Editor. 

9. Open the Exercise3.med included with this tutorial. 
10. Right-click the Job Streams category and select New from the pop-up menu. 
11. The Select Stream Type dialog is displayed. 
12. De-select (un-check) the “Create a new view for this Job Stream.” check-box. A 2D 

View will be created to display the job stream in later steps. 
13. Select Basic Stream in the stream type dialog and press the Next button. 

 The basic stream type is the simplest of the stream types and does not allow 
parametrics of any sort. The other stream types are used to create parametric streams, 
a type of stream where the model is executed multiple times with some type of iterative 
modifications between each task. Parametric stream types are explored in a later 
exercise.  

The list of predefined job streams is displayed. Predefined job streams are used to 
speed the process of creating simple job streams for newly created or newly imported 
models. Predefined streams are plug-in dependent. There are currently no default 
streams for the RELAP5-3D plug-in. 

14. Select An Empty Stream in the stream type dialog then press the Finish button. 

The following steps build a simple stream and submit it for execution. This will export 
an ASCII input file from the source model, copy it to the working directory, and 
execute the RELAP5-3D application defined in Exercise 1 on the file. 
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15. Set the following properties in the newly created stream. 
Property Value 

Name StandPipeStream 
Relative Location DEMO 

16. In the Navigator, expand StandPipeStream. 
17. Right-click on the Stream Steps 

category and select New from the pop-
up menu. 

18. The Select Application dialog is 
displayed, as shown to the right. 

19. Select the appropriate RELAP5 3D 
application from the available list and 
press the OK button. 

A new RELAP5 3D step is added to the stream. 
This is the step that will run the RELAP input 
represented by the model. 

20. Set the Name of the new step to StandPipe. 
21. Set the Interactive Step property to On, and the Start Paused step to On. 
22. Right-click on StandPipeStream and select Create View from the pop-up menu. 
23. Re-position the elements of the new view so that the blue model node is to the left 

of the red RELAP53D node. 
24. Using the Connection Tool in StandPipeStream View, connect the job stream 

model's input point to the StandPipe step's input point. 

The stream step will change color from red to yellow, indicating that its required inputs 
have been connected. 

This simple process represents the most fundamental concept of job streams: connecting 
the outputs of a model, file, or step to the inputs of another step. When this stream is 
executed, the input created by the stream model will be run by the specified RELAP5 3D 
application as its input. 

25. Select Tools → Submit Job from the main menu.  
26. If the Unreviewed Properties warning Dialog opens, press the Yes button. 
27. In the stream submission dialog, make sure that StandPipeStream and Local are 

selected, then press the OK button.  
28. Press OK to confirm the stream submission. 
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The job will be submitted to the Local Calculation Server. Job Status will appear shortly 
thereafter and is described below. Once the stream begins execution, it will perform its 
necessary initialization, then pause until told to proceed. 

The following steps introduce Job Status. This application provides functionality for 
accessing and monitoring streams submitted to a calculation server.  

29. Wait for Job Status to appear after submitting the stream. If Job Status does not 
appear, select from the Start menu: All Programs → SNAP → Job Status. 

30. Job Status is shown in the image below. On the left is a list of known Calculation 
Servers and their mounted-folder hierarchies. The area on the right is a list of the 
jobs residing in the selected folder. 

 

31. Expand Local, then the runs folder, then the Demo folder, and select the 
StandPipeStream folder. 

32. Note that this folder is a different color than those above it. This indicates that the 
directory was created specifically to house the contents of the stream. Selecting 
the stream shows the tasks running in that stream in the table to the right. Notice 
that StandPipe is listed and that its status is Paused. 

This next series of steps will issue an interactive command to the RELAP task, resuming its 
calculation. The interface for this process is the Interactive Commands dialog, which 
allows pausing, resuming, and completely halting jobs. The dialog also allows changing the 
values of interactive variables. 

Note: Terminating the run outside of the Interactive Commands dialog terminates the 
process, which may produce corrupted output files. 
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33. Select StandPipe row in the table to the right. 

34. Press the Interactive Commands button (  ) on the toolbar above the job list. 
35. The Interactive Commands dialog is displayed, as 

shown in the figure to the right. 
36. Press the Resume button. 
37. The Status of StandPipe changes from Paused to 

Interactive, and the calculation resumes. 
38. Close the Interactive Commands dialog by 

pressing the Done button, then wait for the job to 
complete. 

39. In the Job List, expand Local, and select the /runs/DEMO/StandPipeStream folder. 

40. Press the View Output button (  ). 
41. This will open a pop-up menu of available files related to the job. Files are broken 

down into several types, as shown in the image below. Selecting any items in the 
Text Files menu will open the Output Viewer, described below. 

42. The RELAP5 3D StandPipe job provides several files which can be opened by the File 
Viewer.  

Some notable files include: 

• Input - StandPipe.inp. The input file submitted to the RELAP5 3D executable. 
• output - StandPipe.out. The results of the calculation in ASCII form. 
• screen - StandPipe.screen. A collection of messages written to the console 

during the run. 
• Task Log – The Log file in the Calculation server for this job task. 

43. From the pop-up menu, select the output entry. 

The File Viewer will appear and display the contents of the file. The File Viewer was 
designed to allow very large text files on a remote Calculation Server to be viewed and 
searched over a relatively slow connection. 

44. Press the Points of Interest ( ) button. 

The Points of Interest search dialog will be displayed. The points of interest in the file are 
separated by type into expandable sections. Expanding each section will show the list of 
points of interest of that type in the file and the line number on which it has occurred. 

For RELAP5 3D output files the points of interest include major edits, error messages, and 
warning messages. 

45. Click on the Major Edits row to expand the list of major edits. 
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This will expand the Major Edits row to display the list of major edits in the file and will 
automatically select the first major edit in the list. 

Notice that the File Viewer is now positioned at the beginning of the first Major Edit. Each of 
the Points of Interest provided will navigate to the point in the output where the item can be 
found. 

46. Close the Points of Interest window. 
47. Close the File Viewer 

This concludes the Simple Job Stream Exercise. Leave the current model open in the Model 
Editor to continue to the next exercise. 
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Exercise 5. Animating Results 
This exercise introduces creating a simple animation of a completed run. This animation 
will include a graphical representation of the stand pipe. An axial plot of liquid 
temperature, and interactive controls for the model elements. 

1. Open the Model Editor and open the 
Exercise4.med model included with this tutorial. 

2. Select the File → New menu item.  
3. Select Animation Model and press the OK button. 
4. Click Exercise4.med in the Navigator. 
5. Select the Default View. 
6. Right-Click the view and click the Select →All 

menu item. 
7. Right-Click on a selected component and choose 

the Copy menu item. 
8. Select the unnamed Animation model. 
9. Right-click in the view and select Paste. 

 

The view should match the above image. Notice that the interactive variables include a text 
field. When the view is locked, these text fields can be used to manipulate the input of the 
interactive variable as the code is executing. 
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10. Expand the Data Sources node in the Navigator. 
11. Select the Master node. 
12. Open the Source Run URL property editing dialog. 
13. Navigate to the DEMO/StandPipeStream node in the Stream Tree. 
14. Select the StandPipe in the Job Table and press the OK button. 

15. In the Main Toolbar press the Connect button ( ). 

Notice that all the display elements in the view change color when connected to the 
animation source. 

16. In the playback controls press the Play button ( ). 
17. Watch the animation play. 
18. While the playback is running, expand Color Maps in the Navigator. 
19. Select Fluid Condition Color Map. 
20. Set the Color Map Type to Void Fraction. 
21. Wait for the animation to complete. 

22. Set the Color Map Type back to Fluid Condition. 
23. Drag a selection rectangle around the Pipe Pressure Drop object set. 
24. Drag the select elements below the Valve Controller block. 
25. Use the Insert Tool to select Graphs -> Axial Plot. 
26. Click and drag a rectangle to the right Pipe 8. 
27. Set the Color Map to Temperature Color Map. 
28. Set the Orientation to Vertical. 
29. Open the Plot Data property editing dialog. 
30. Press the Add button in the bottom panel until there are 20 rows. 
31. Select the X Position column values. 
32. Press the Set button. 
33. Set the First Value to 0.15. 
34. Set the Increment to 0.3. 
35. Press the OK button. 
36. Select the Y Channel Names column values. 
37. Press the Set button. 
38. Set the Pattern to ‘httemp-110%2X01’ 

In the steps we will connect to a previously run exercise, and animate the results. 

In the steps we will create an axial plot that shows the outside temperature of the 
heat structure on the outside of Pipe 8. 
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39. Press the OK button. 
40. Set the Selected Data Set label to Wall Temp. 
41. Press the OK button. 
42. Set the Show Title property to False. 
43. Set the Show Legend to False. 
44. Set the Plot Background to White  (255, 255, 255). 
45. In the Main Toolbar press the Rewind button. 
46. Then press the Play button.  View should resemble the below image. 

 

47. Select the Exercise4.med model. 
48. Submit the Job Stream again by Right-clicking the StandPipeStream in the Navigator 

and selecting the Submit Stream to Local menu item. 
49. Press OK in the submit stream. 
50. Press Close in the Submission Report dialog. 
51. Select the Animation Model. 
52. Lock the view and connect the animation by pressing 

the Connect button. 
53. Press the Play button. 
54. Click in the Valve Pos text field and type 1.0 and hit 

enter. 

Notice the Valve icon in the view turns green to indicate the 
valve is open. 

This concludes the animation exercise. Feel free to continue to play with the interactive 
variables controlling the flow speed and heat structure temperatures. 


