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Introduction
This set of exercises is designed to provide basic instruction on how to configure SNAP and how 
to use many of the model editing capabilities in SNAP. The following topics are covered:

• Editing an existing model in the Model Editor.

• Creating new component in a model.

• Connecting components using the connect tool.

• Duplicating components using copy/paste.

• Manipulating drawn components in a view.

These exercises assumes you have properly installed the SNAP software along with the 
following applications:

• The AptPlot plotting package. (http://www.aptplot.com)

• The jEdit editor. (http://www.jedit.org  )

• Adobe Acrobat Reader. (http://www.adobe.com  )

• TRACE Executable

• The following software will be needed for later exercises: 

Please refer to your system administrator or the installation instructions located on the SNAP 
website (http://www.nrcsnap.com) if you have any questions concerning installation.
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Exercise 1. Configuring SNAP
The following exercise provides a set of instructions for configuring a new SNAP installation for 
this workshop on a Windows system. The SNAP runtime was designed to work with a minimal 
amount of configuration, therefore most options can be left at their default values. The following 
steps assume that SNAP has not been previously configured on the system and that all properties 
are currently at their default values.

1. Open the Configuration Tool by selecting All Programs → SNAP → Configuration 
Tool from the Start Menu.

2. Select your AptPlot executable by pressing the S button located to the right of the 
Plotting Tools property. 

This will open a file selection dialog. 

3. Navigate to the AptPlot installation directory and select the AptPlot.exe file located 
under the bin directory, then press the Open button.

4. Select your jEdit installation folder by pressing the jEdit button ( ) to the right of the 
jEdit Executable property.

This will open a directory selection dialog. If jEdit is not installed, skip this step.

5. Navigate to and select your jEdit installation directory, then press the Open button.

A prompt will appear, indicating that the SNAP jEdit installation was successful.
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6. Dismiss the prompt by pressing the OK button.

Note: Matlab can be configured for use as an external function calculation engine. 
This requires defining the location of the Matlab executable in the Configuration 
Tool. This is not required for this workshop.

7. Expand the Applications node in the tree on the left.

This will display the applications available for execution as part of a SNAP Job Stream. 
The applications currently displayed (if any) are those automatically defined as part of a 
SNAP installation. The next several steps will define the TRACE application used 
throughout these exercises.

8. Right-click on the Applications node and select New from the pop-up menu.

The Create Application dialog is displayed, listing the available application types.

9. Select TRACE from the list of applications and press the OK button.

A new, unspecified TRACE executable will be created for use in SNAP models. The new 
application should be selected with its properties displayed on the right. If not, follow the
next step.

10. Select the Unspecified TRACE application in the Applications list.

The properties to the right will change to reflect those of the selected application. 

11. Set the Name property to “TRACE”.

Typical application definition names for a TRACE executable might indicate the version 
or build number such as “V501147” or “V50P5”.

12. Enter a description for the TRACE executable by pressing the E button next to the 
Description property.
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13. Press the S to the right of the Local Location property, located in the Application 
Locations group.

A file browser will appear. This dialog is used to select the location of the executable on 
the local machine.

14. Navigate to the location of the TRACE executable, select it in the file browser, then press 
the Select button.

15. Locate the Application Version property and make sure it is set to
“TRACE:V 5.0 Patch 5”.

The flavor and version of the application being defined. This serves as as an additional 
indication to the job step of how this application should be handled.

16. Save the configuration by either selecting File → Save All from the main menu or by 
pressing the Save button ( ) in the tool-bar.

17. Exit the Configuration Tool.
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Exercise 2. Editing an Existing Model
This exercise is designed to familiarize the analyst with the basic editing capabilities of the 
SNAP Model Editor using the TRACE plug-in. The following steps act as a guide through 
editing an existing TRACE model in SNAP. This exercise will cover a series of important topics 
including creating new components, editing component attributes, basic undo/redo functionality, 
and engineering units.

The exercise will take a simple stand pipe model, reduce the pipe length by half, and add a 
crossflow connected valve so that the resulting model appears as displayed below:
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The first step is to open the ModelEditor application. Under Windows, select the “All Programs 
→ SNAP → Model Editor option from the Start menu. This will open the ModelEditor and 
display the welcome dialog shown below:

1. Select the Open a Model Document → Continue >> option.

A file selection dialog will appear that is used to select a model file to open.

2. Locate and select the standpipe model provided with this exercise and open the model. 
(SNAP_Exercises/StandPipe1.med)

3. From within the navigator select and expand the Hydraulic Components → Pipes 
categories and select Pipe 1. 

The TRACE plug-in includes a property editor for each component attribute. Many of 
the attribute editors provide convenience functions such as copy/paste and plotting table
data in addition to the basic data entry function. Note that the initial conditions property
editor indicates that it contains invalid cell initial conditions.  

4. Select the Show ASCII item from the right-click pop-up menu item of the Pipe's 
navigator node.

Each of the components in the TRACE plug-in provide a Show ASCII menu item which 
displays the input of the selected component. The ASCII view is automatically updated 
when any of the component's properties are modified. The ASCII view window highlights
card numbers, comments, and unknown values in distinguishing colors.

5. Specify the model units by opening the right-click pop-up menu from the model node in 
the Navigator and selecting British from the Engineering Units menu.
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Notice that each of the attributes are automatically converted to the appropriate value in
British units. The TRACE plug-in allows a user to specify the engineering units a model 
is defined in. For this exercise we will be describing each of the values in British units. 

6. From within Pipe 1's property view, locate and open the property editor associated with 
the Component Geometry attribute.

The pipe geometry editor provides a series of columns and tabs for defining Pipe 
geometry data. The dialog is divided into two main segments, a component view and the 
property table. Each row in the table corresponds to a cell or edge. Selecting a cell/edge
in the view will highlight the row in the table corresponding to the selected cell/junction.
Selecting a row in the table highlights the cell/edge the table cell represents. Many of the
table editors in the TRACE plug-in provide column header tool-tips which can further 
describe the values being edited.

7. Set the Calculate option to Volume and highlight all of the Length cells in the table.

Cell geometry in TRACE is defined by specifying any two of the Length, Area, or Volume
properties. The third property is then calculated from the entered data.  

8. Type in a length value of 0.3 ft and press Enter.

Note that the ASCII view updates when the value is modified. The last row in the 
geometry dialog displays the column totals for the volume and length data.

9. Undo the modifications made to Pipe 1's lengths by selecting the Undo Cell Geometry 
Edit option from the Model Editor's Edit menu.

Modifications performed in the Model editor can easily be undone and redone. This will 
update the editor and ASCII view to reflect the pipe a the length modifications were 
made.

10. Select the Redo Cell Geometry Edit option from the Model Editor's Edit menu.
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11. Close the Component Geometry editor.

12. Scroll to the Gas Volume Fraction (alp) values in the ASCII Viewer and click on the third
row of values.

The ASCII Viewer includes a toolbar with a brief description of the input at the current 
cursor location. Clicking on a supported portion of the input will update the cursor 
location and enable the Edit toolbar button. Pressing the Edit button will open the 
graphical editor corresponding to the current cursor location.

This same behavior is available for the entire model in the SNAP Validation Display 
which can be opened by pressing the Validation Display ( ) button on the Model 
Editor's main toolbar.

13. Press the Edit button at the top of the ASCII Viewer to open the Initial Conditions 
editing dialog.

This will display the dialog shown below. 
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14. Click the Gas Volume Fraction entry for the first cell and enter 0.0. 

15. Highlight the first cell in the Gas Volume Fraction column and choose the right-click 
pop-up menu Copy item to place the value on the clipboard.

Most tables in SNAP will allow you to copy and paste data values to and from 
spreadsheets, tab-delimited ASCII files, as well as between SNAP tables.

16. Using the mouse, click and highlight the Gas Volume Fraction for cell 2 then drag the 
pointer to the last cell so that all of the remaining void fraction values are selected. 

17. Right-click on the table to open the table pop-up menu and select the Paste item. 

The remainder of the table should now be filled and the ASCII view will automatically 
update to reflect these changes. 

18. Select the first cell in the Pressure column and hold the Shift key. 

19. While holding down the Shift key, scroll to and click the last cell in the table.

20. Type a pressure value of 515 psi and press Enter.

The editor will automatically calculate and set the temperature values of the liquid and 
gas using the built in steam tables.

Notice that the attribute editor for initial conditions now indicates “[Valid Conditions]” 
have been entered.

21. In the same dialog, select the Edges tab.

22. Set all Liquid Velocity values to 0.88 ft/s by selecting the liquid mass flow for junction 
1 and dragging the cursor to the last junction to highlight all of the table cells and then 
entering the value 0.88 ft/s.
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Notes:

The Shift and Control keys can be used to add contiguous ranges and individual cells to 
the current table selection, respectively. 

When pasting a single value into a table, all selected values will be updated.

When pasting a set of multiple values from a spreadsheet, values are updated in a 
one-to-one manner until either the number of values contained on the clipboard or the end
of the selection is reached. 

23. Close the dialog and the ASCII view.

In the next few step we will add a discharge valve and some interactive control system 
components to the model.

24. Locate the Hydraulic Components → Valves category in the Navigator.

25. Create a new valve by selecting New from the Valves right-click pop-up menu.

26. Set the following values in the provided Valve completion dialog and then press the OK 
button:

Hydraulic Diameter: 0.48 ft
Number of Cells: 0
Orientation: Horizontal

27. Set the valve Component Number to 51 in the property view.

28. Locate the view labeled “Default View” from the Views category in the Navigator and 
select Open from the view's right-click pop-up menu.

29. Drag the valve off the Navigator and to the right hand side of pipe 1 cell 19.

The next steps will use the connect tool to connect the inlet of the valve to the cross-flow of pipe 
1 cell 19.

30. Select the connection tool  from the view tool-bar.

31. Click on the circle on the left side of the valve.

32. Click on the diamond on the right side of the next-to-last cell of the pipe.

Refer to the figure for the proper connecting point location. 

The cursor will change to a target when the connect tool is selected. When the cursor hovers 
over the connection point located at the inlet of the valve a set of cross-hairs will appear in 
the target indicating that a connection can be made from this point. 
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Clicking the left mouse button while the cursor is on a
connection point will initiate a connection. A rubber band line is
created from the connection point to the cursor. A filled blue
circle will appear when the cursor hovers over a valid target
connection point.

Move the cursor to the target connection point and click the left
mouse button to create a connection.

Notes: 

While a connection is being made, left clicking anywhere other
than a valid connection point will create intermediate line
segments for the connection.

Right clicking while creating a connection will remove the last
intermediate line segment or will cancel the connection if there
are no intermediate segments. The escape key can also be used to
cancel a connection. 

Connections have a right-click pop-up menu that can be used to
add or remove points, to remove the connection from the view
(cut) or to delete the connection from the model.

33. Choose the Select tool  from the view tool-bar. 

34. Select the newly created drawn connection line in the view.

35. Set the target component theta Angle property to 0.0 deg.

36. Create a new Break from the Navigator.

37. Drag the newly created Break onto the 2D view to the right of the valve.

38. Connect the valve outlet junction to the Break inlet junction using the connect tool.

39. Choose the Select tool  from the view tool-bar. 

40. Right click on the newly created Break drawing and set its Drawn Orientation to 
Right. 

41. Select the valve in the navigator and locate the Valve Type attribute in the Property 
View.

42. Set the Valve Type to [1] Flow Area Fraction Table

43. Open the editor associated with the Valve's Component Geometry attribute.

44. Set the valve Flow Area to 0.05 ft2 and close the editor.

45. Set the following values in the Valve property view:

Maximum Valve Rate:  1.0 (1/s)
Off Adjustment Rate: 0.0 (1/s)
Minimum Position: 0.0
Maximum Position: 1.0
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Valve Flow Area:  0.05 ft2

Valve Hydro Diameter:  0.48 ft
Initial Flow Area Fraction:  0.0
Valve Stem Position: 0.0

46. Next, select the Break attached to the valve component and specify the following values 
in the property view:

Component Number:  20
Length:  0.6 ft
Volume: 0.1086 ft3

Initial Gas Volume Fraction: 0.0
Initial Mixture Temperature: 470.0 F
Initial Pressure: 515.0 psi

The next steps will use the insert tool to create new interactive controls for the model. These 
controls will be used to initialize and change the liquid flow rate, the valve flow area, and the 
surface heat flux of the outside surface of the heat structure.

47. In the 2D view, select insertion tool  and expand the drop down menu to select 
“Control Systems → Control Blocks”.

This will define that the insert tool will create new control blocks. After clicking the 
mouse once, the mouse tool will automatically revert to the select tool.

Note: The component insertion tool is located within the 2D view tool-bar as a 
drop-down menu. Selecting a component from the drop-down menu allows the user to 
create the specified component and place it in the 2D view. This method is an alternate to
creating the component from the category New right-click menu items.

48. Click the mouse, using the insert tool to the left of Pipe 1, below the Interactive TRACE 
Demo text label.

49. Select type [-9] Interactive Variable in the provided completion dialog and press OK.

50. Verify that the Type of the Controller Block is [-9] Interactive and set the properties of 
the interactive variable as follows:
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Control Block Name: heatflux
Variable Name: Heat Flux

51. Construct another Interactive variable using the 2D insertion tool.

This will be used as the valve stem position controller.

52. Specify the following information for the newly constructed interactive variable:

Control Block Name:  valvepos
Minimum:  0.0
Maximum:  1.0
Constant 1:  0.0
Variable Name: Valve Area

53. Construct another Interactive variable using the 2D insertion tool.

This will serve as the inlet flow velocity controller.

54. Select the newly constructed interactive variable and specify the following information:

Control Block Name:  invel
Constant 1: 0.88
Variable Name: Inlet Vel

The next step is to connect the previously created interactive controllers to their associated 
hydraulic components.

55. Select Fill 11 and open its Fill Table property editor.

56. Set the Independent Variable to the invel interactive controller.

57. Press OK to close the dialog.

The connection between the fill and the interactive controller in the 2D view will be 
indicated with a green dotted line.

58. Next select the valve component and set its Valve Table Indep. Var. property to the 
valvepos interactive controller.

59. Press OK to close the dialog.

60. Open the editor for the First Adjustment Table property in the valve property view.

61. Press the Add button twice to add two rows to the table.

62. Set the cells in the first row to: 0.0, 0.0.

This tells the valve to set the flow area fraction to 0.0 when the interactive variable 
provides a 0.0 value.

63. Set the cells in the second row to: 1.0, 1.0

This tells the valve to set the flow area fraction to 1.0 when the interactive variable 
provides a 1.0 value.

64. Press the OK button to save the values and close the dialog.

65. Select “Thermal →Heat Structures →Heat Structure 31” in the Navigator.
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66. Open the editor for the Axial Nodes / Surface BCs property.

67. Select Axial Cells 5 through 20 in the Outer Surface Boundary Conditions column.

68. Set the Boundary Condition property to [10] Controlled Heat Flux.

69. Set the Control Signal property to the heatflux interactive controller.

Next we will configure the heat structure to reflect changes made to the pipe length and initialize 
its temperature values.

70. Select all of the cells in the Axial Cell column.

71. Set the Length property of the nodes to 0.3 ft.

This reflects the modification made in an earlier step to Pipe 1 where we cut the length 
of the nodes from 0.6 ft from 0.3 ft.

72. Press the OK button to accept the changes and close the dialog.

73. Open the Initial Temperature property editor.

74. Highlight all of the cells in the table, type in value 470.0, and press Enter.

This will set the initial temperature of the radial nodes of the heat structure to 470.0 F

75. Verify that all of the values are set to 470.0.

76. Press the OK button to accept the changes and close the dialog.

In the next few steps we will add some basic annotations to the view.

77. Select the “Annotation →  Text Annotation” item from the view insert tool drop-down 
menu.

78. Click on the view just below the heatflux interactive variable created earlier.

79. Enter “Heat Controller” as the Text property.

80. Set the Font to “Dialog, Bold, 12”  by selecting the bold 'B' character in the font 
selection editor.

81. Select the “Annotation →  Rectangle” item from the view tool-bar
drop-down menu.

82. Use the insert tool to surround the new text annotation and the control
component.

Note that the rectangle is drawn over the top of these items and prevents
them from being seen.

83. Open the right-click pop-up menu on the new Rectangle and select the 'To Back” option.
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84. Repeat this procedure to add labels and boxes around the Inlet Velocity Controller and 
Valve Controller control systems we created earlier.

The resulting view should resemble the one shown below:
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Exercise 3. Working with Model Views
This exercise is designed to build upon the model created in Exercise 2 and continue introducing 
model building elements of SNAP. This exercise will cover topics including copying and pasting 
components, creating small control networks, basic undo/redo functionality, and engineering 
units.

The exercise will take a simple stand pipe model, duplicate the pipe, and insert the duplicated 
component between the existing pipe and the outlet. The resulting system will match the system 
displayed below:
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1. If you do not have the model from Exercise 2 open, open the file 
SNAP_Exercises/StandPipe2.med included with these exercises.

2. Expand the Views Navigator node. 

Models can contain any number of 2D views. These views are loaded and saved with the
model. Views contain 2D drawn representations of many types of model components and
provide tools to help describe those components. The views can contain annotations, 
background colors, grid, etc.. Views allow component searching using the binocular 
icon provided in the view tool-bar. Zoom options are available by selecting the 
magnifying glass icon or using the right-click menu.

In the next steps we will create a duplicate copy of the pipe component and a simple control 
system to generate a display value. 

3. Select the Hydraulic Components → Pipes → Pipe 1 node in the Navigator and select 
the Copy option from its right-click pop-up menu.

4. Choose the Paste Special option from the right-click
pop-up menu of the Pipes category node.

5. Select the Offset Component Numbers By option and set
the offset to 1.

The paste special dialog allows a user to create multiple
copies of the same component starting at a specific offset
with a specific number increment. This also allows users to
copy/paste model components within the same model or
into a separate model.

6. Press the OK button to paste the component. 

7. Locate the view labeled “Default View” and select Open
from the view's right-click pop-up menu.

Note: The view's pop-up menu also includes a print option.

8. Expand the Hydraulic Components category in the
Navigator and drag Pipe 2 onto the view just above Pipe 1.

All components which have a 2D representation can be dragged onto a 2D view. Only 
one instance of each component can exist in a view (no duplicates of the same 
component are allowed in the same view). Components which have connections to other 
components in that view will automatically draw those connections when they are 
inserted into the view.

9. Right-click on Pipe 2 in the view and select the Scale Drawing menu item.

10. Set the Length Scale Factor to 5.95, the Width Scale Factor to 10.0, and press the OK 
button.

11. Select the background of the 2D view to bring up the views properties.

12. Locate the Canvas Size property and re-dimension the views height to be 900 pixels.
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This will increase the amount of vertical space we have available so that there is 
adequate space for adding and moving components in the view.

13. Select the connection from the outlet of Pipe 1 to Break 21.

14. Select the Disconnect option from the right-click pop-up menu.

Note: The undo/redo functionality can be used to resolve any issues where a component 
or connection has been mistakenly added or removed.

15. Select the connection tool  from the view tool-bar and create a connection between the
inlet of Pipe 2 and the outlet of Pipe 1. 

16. Use the connection tool  to create a connection between the outlet of Pipe 2 and the 
inlet of Break 21.

17. Choose the Select tool  from the view tool-bar. 

18. Use the view's left-click rubber-band tool to select each of the display components which
are arranged vertically. (This does not include the valve or its connected Break)

19. With the components selected, open the view right-click pop-up menu and select the 
Align → Center ( )item.
This will cause the components to center around a common vertical axis.

In the next steps, the heat structure that was originally duplicated along with pipe 1 will be 
removed and replaced with a new heatstructure.

20. In the Navigator select Heat Structure 32 and select Delete from the right-click pop-up 
menu.

Components which are deleted can be restored
using the undo functionality.

21. Select the Copy item from the right-click pop-up
menu of Heat Structure 31.

22. Select the Heat Structures Navigator category
node and select the Paste Special option.

23. Set the Offset Component Number property to 1
in the provided dialog and press the OK button.

24. Select the newly created Heat Structure in the
Navigator.

25. Open the editor for the Axial Nodes / Surface
BCs property.

26. Select all of the cells in the Inner Surface
Boundary Conditions column and open the 
Hydraulic Cell property editor in the lower
property view.
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27. Change the referenced pipe value to the newly created pipe by opening the editor next to 
the Hydraulic Component property and selecting pipe 2 from the list. 

Once the Pipe has been selected as the Hydraulic
Component, two spinners will appear to allow the
selection of the range of hydraulic cells to map to
the selected Heat cells.

28. Press the OK button to save the value and close
the dialog.

29. Verify the Starting Cell is set to 1 and the Ending
Cell is set to 20.

30. Press the OK button at the bottom of the Heat
Connections editor.

Next we will set the heatflux controller on the lower
portion of the pipe.

31. Select the first four axial cells in the Outer
Surface Boundary Conditions column.

32. Set the Boundary Condition property to 
[10] Controlled Heat Flux.

33. Set the Control Signal to the heatflux controller.

34. Select the last 4 axial cells (17-20).

35. Set the Boundary Condition property to [0] Constant Heat Flux.

36. Press the OK button to accept the changes and close the dialog. 

In the next steps a control block summer will be created to determine the pressure drop across the
two pipes. Two signal variables will be created signifying the pressures at opposite ends of the 
pipes. 

37. Using the insertion tool, select Control Systems → Signal Variables.

38. Insert the first signal variable on the view below the valve component.

39. Select type [21] Pressure in the provided completion dialog.

40. Insert the second signal variable directly below the last signal variable and again set the 
type to [21] Pressure in the provided completion dialog.

41. For the upper signal variable, open the editor for the Signal property.

42. Set the Hydraulic property to Pipe 1, the Cell to 1, and press the OK button.

43. For the lower signal variable, open the editor for the Signal property.

44. Set the Hydraulic property to Pipe 2, the Cell to 20, and press the OK button.

The signal variables will be supplied to a subtract block in order to determine the 
pressure drop across the pipes. 
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45. Using the insert tool drop-down menu, place a control block on the view to the right of 
the signal variables.

The placement should be similar to the following figure.

46. Select [54] Subtract when prompted from the completion dialog. 

47. Set its Control Block Name property to deltaP.

48. Using the connect tool, connect the signal variables to the subtract block by connecting 
the upper signal variable to the upper connection point and the lower signal variable to 
the lower connection point.

49. Select the Annotation →  Text item from the view insert tool drop-down menu and 
click on the view just above the new control network.

50. Enter “Pipe Pressure Drop” as the Text property.

51. Set the Font to “Dialog, Bold, 12”  by selecting the bold 'B' character in the font 
selection editor.

52. Select the Annotation →  Rectangle item from the view tool-bar drop-down menu and 
use it to surround the new text annotation and the control network. 

53. Open the right-click pop-up menu on the new Rectangle and select the 'To Back” option.

In the next section we will add some red lines adjacent to the pipe to signify the regions where 
power is being added to the heat structure.

54. Select the Annotation → Line annotation from the view tool-bar drop down menu and 
place a vertical line along the left side of Pipe 1, starting at the fourth vertical level from 
the bottom and extending to the topmost level of Pipe 1.

55. Set the First Arrow Head and Second Arrow Head properties to None.

56. Set the Color property to 255,0,0 and then close the dialog.

57. Use the right-click Copy/Paste menu items to copy the line to the right hand side of the 
Pipe and verify that it is placed at the same vertical position. 

These lines are a simple indicator of where the heatstructure powers the Pipe. The 
TRACE plug-in supports a series of annotation objects including text, rectangle, 
polygon, ellipse, image, and line.
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58. Copy one of the lines created in the previous step to left hand hand of Pipe 2.

Position the line such that the top of the line begins at the bottom of the fourth cell from the 
top of the pipe and stretches to the bottom of the pipe.

59. Repeat these steps to place an annotation to the right-hand side of Pipe 2. 

60. Select the background of the view and open the right-click pop-up menu. Locate and 
select the Zoom option.

This opens the view zoom and scaling options pop-up dialog. This dialog allows 
controlling the zoom, the view size, and the view scaling factors in one convenient 
location.

61. Click on the red arrow ( ) to bring up the zoom shortcut pop-up menu.

62. Click the Fit to Window option from the zoom shortcut menu. 
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This option adjusts the zoom in a view to display all of the drawn components and 
annotations inside that view.

63. Select the background of the view and open the right-click pop-up menu, locate the 
Tools option, and select Trim Excess Canvas.

Note: The Trim Excess Canvas option can be used to easily reduce the canvas size to be 
the bounds of the components contained in the view.

In the next few steps we will use component grouping to group up each of the control systems 
and their associated annotations.

64. Locate the Pipe Pressure Drop control system block in the view and use the right-click 
rubber-band select tool to highlight the rectangular annotation, text annotation, and 
components.

65. With each of the pressure drop components selected, open the right-click pop-up menu 
and choose the Group option.

66. Select the Pipe Pressure Drop group and move the block until it is above the valve.

Notice that component grouping locks each component into a visual group. The elements
in the group cannot be selected individually unless the group is first broken. As the 
group is moved, each of the items belonging to the group move with respect to their 
location within the group. Individual components can only be added to one group, 
although groups can be combined with other groups.

67. Select the individual controller block components and group them using the procedure 
defined above. 

The next few steps we will demonstrate additional view features.

68. In the property view of the Default View, locate the Display Icon attribute and select the 
camera icon to grab a snapshot of the current state of the view.

69. Press the OK button to accept the default image size.

70. Create a new view by selecting the Views category node in the Navigator and selecting 
the New option from the right-click pop-up menu.

71. Set the Name of the view to Embedded Views.
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72. In the new view, select the Annotation → Views option from the view tool-bar 
drop-down and left-click inside the view to insert an embedded view.

73. Select the “Default View” in the dialog which identifies the view to embed in our current
view and press the OK button.

74. Double-click on the embedded icon to switch to the Default View.

More than one embedded view can be placed within a view to provide convenient 
navigation between views.

75. Once again bring up the right-click pop-up menu for the Default View and locate the 
Export Image option. 

76. Select the Entire View option and choose JPEG Image.

Note:  Either the entire view or current perspective can be exported. The image exporter 
supports the following formats: JPEG, PDF, PNG, SVG, and TIFF. Additionally, the 
view can be exported to the system clipboard to paste the image into external 
applications such as MS Word.

77. Export the image as modelview.jpg using the default image settings.

Image size and scale can be modified by the dialog which is provided after a filename 
has been specified.

78. Open the exported image and verify that it is an accurate representation of the exported 
view. 

The next few steps will demonstrate reusing established views through the use of the SNAP view
template feature. View Templates provide a means of saving a layout of a view that may then be 
applied to a similar model.

79. Create a new empty View by right-clicking on the Views node in the Navigator and 
selecting the New menu item. 

This should create and open a new View with the name "View 1" and display its 
properties in the Main Property View.

80. Open the view pop-up menu by right-clicking anywhere inside the empty view (the 
pop-up from the Navigator node does not contain the necessary menu item). 

81. Select "Tools→Import View Template" in the pop-up. 

82. At the file browser, select the file standpipe.mvt provided with these exercises 
(SNAP_Exercises/standpipe.mvt) and press Open. 
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This will apply the template to
the view, which should now
appear as shown below:

Note: To export a View
Template of an existing view,
use the "Tools → Export View
Template" item off the
right-click pop-up menu in the
View.
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Exercise 4. Introduction to Job Streams
This exercise introduces the basics of building Job Streams in the SNAP Model Editor. A stream 
consisting of a single TRACE step will be submitted to the local Calculation Server. Afterward, 
the stream will be monitored from the SNAP Job Status application and the task output 
examined.

The following steps set up a runs folder on the Local Calculation Server. This is the location in 
which streams will be run through the exercises. If the SNAP configuration for the Local 
Calculation Server already contains a suitable submit location, skip the next six steps and use this
folder whenever the exercise refers to the runs directory.

1. Open Job Status. On Windows, select from the Start menu: All Programs → SNAP → 
Job Status.

2. In the tree to the left, expand the Local node. If a prompt appears asking whether to start 
the Calculation Server, press Yes.

Expanding this node connects to the Local Calculation Server.

3. At the No Root Folders prompt, press Yes.

A file browser will appear. This is used to select a location on the server where streams 
can execute.

4. In the file browser, navigate to a suitable run directory or create one. Press the Mount 
button once the folder is selected.

A prompt will appear asking for the name of the new mount point.

5. Enter the name “runs” for the folder and press the OK button.

The runs folder will appear under Local.

6. Close Job Status.

The following steps build the simple stream and then submit it.

7. Open the Model Editor. On Windows, select from the Start menu: All Programs → 
SNAP → Model Editor.

The Model Editor will start up and display a welcome screen. Note that the welcome 
screen can be disabled and may not appear.

8. On the welcome screen, select the Open a Model Document → Continue >>  option. 

A file selection window will appear prompting for the model to open. If the welcome 
screen was not displayed, select “File → Open” from the main menu.

9. Open the standpipe sample model provided with this exercise. This file is located at 
“SNAP_Exercises/StandPipe3.med”

After a moment, the model will be completely loaded and its primary view will be 
displayed. This is the model that will be submitted to the Calculation Server, which is 
covered in the next several steps.
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10. Right-click the Job Streams category and select New from the pop-up menu.

The Select Stream Type dialog is displayed, as shown below.

11. De-select (un-check) the “Create a new view for this Job Stream.” check-box.

A 2D View will be created to display the job stream in later steps.

12. Select Basic Stream in the stream type dialog and press the Next button.

The basic stream type is the simplest of the stream types and does not allow parametrics 
of any sort. The other stream types are used to create parametric streams, a type of 
stream where the model is executed multiple times with some type of iterative 
modifications between each task. Parametric stream types are explored in a later 
exercise.

The list of predefined job streams is displayed. Predefined job streams are used to speed 
the process of creating simple job streams for newly created or newly imported models. 
This exercise will start with an empty stream in order to examine the job stream creation 
process mode closely.

13. Select An Empty Stream in the stream type dialog then press the Finish button.

A new basic job stream is created and selected in the Navigator.

14. Set the following properties in the newly created stream:

Name: StandPipeStream
Platform: Local
Root Folder: runs
Relative Location: TRACE/

15. In the Navigator, expand StandPipeStream.

A set of child categories are shown, including Stream Steps and Model Nodes.
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16. Right-click on the Stream Steps category and select New from the pop-up menu.

The Select Application dialog is displayed, as shown below.

17. Select the appropriate TRACE application from the available list and press the OK 
button.

A new TRACE step is added to the stream. This is the step that will run the TRACE input 
represented by the model.

18. Set the following properties on the new TRACE step:

Name: StandPipe
Interactive Step: On
Start Paused: On

Interactive Step and Start Paused will ensure that the TRACE job is run in interactive 
mode and, after a short initialization phase, waits before executing.

19. Expand the Model Nodes category in StandPipeStream.

A single “model node”, TRACE model 1, will appear in the category. This node 
represents the StandPipe model.

20. Right-click on StandPipeStream and select Create View from the pop-up menu.

A view will be created with the model node and the TRACE step.

21. Re-position the elements of the new view so that the blue model node is to the left of the 
red TRACE node.
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22. Using the Connection Tool in StandPipeStream View, connect the job stream model's 
input point to the StandPipe step's tracin point.

The stream step will change color from red to yellow, indicating that its required inputs 
have been connected.

This simple process represents the most fundamental concept of job streams: connecting 
the outputs of a model, file, or step to the inputs of another step. When this stream is 
executed, the input created by the stream model will be run by the specified TRACE 
application as its tracin input.

23. Select “Tools → Submit Job” from the main menu.

The stream submission dialog is displayed, as shown.

24. In the stream submission dialog, make sure that StandPipeStream and Local are 
selected, then press the OK button.

25. Press OK to confirm the stream submission.

The job will be submitted to the Local Calculation Server. Job Status will appear shortly 
thereafter and is described below. Once the stream begins execution, it will perform its 
necessary initialization, then pause until told to proceed.

The following steps introduce Job Status. This application provides functionality for accessing 
and monitoring streams submitted to a calculation server. In particular, the next several steps will
examine the paused TRACE task created above and resume its calculation.

26. Wait for Job Status to appear after submitting the stream. If Job Status does not appear, 
select from the Start menu: All Programs → SNAP → Job Status.
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Job Status is shown in the image below. On the left is a list of known Calculation Servers 
and their mounted-folder hierarchies. The area on the right is a list of the jobs residing in
the selected folder.

27. Expand Local, then the runs folder, then the TRACE folder, and select the 
StandPipeStream folder.

Note that this folder is a different color than those above it. This indicates that the 
directory was created specifically to house the contents of the stream. Selecting the 
stream shows the tasks running in that stream in the table to the right. Notice that 
StandPipe is listed and that its status is Paused.

This final series of steps will issue an interactive command to the TRACE task, resuming its 
calculation. The interface for this process is the Interactive Commands dialog, which allows 
pausing, resuming, and completely halting jobs. The dialog also allows changing the values of 
interactive variables.

Note: Terminating the run outside of the Interactive Commands dialog terminates the process, 
which may produce corrupted output files.

28. Select StandPipe row in the table to the right.

29. Press the Interactive Commands button
( ) on the toolbar above the job list.

The Interactive Commands dialog is
displayed, as shown in the figure to the
right.

30. Press the Resume button.

The Status of StandPipe changes from 
Paused to Interactive, and the
calculation resumes.

31. Close the Interactive Commands dialog
by pressing the Done button, then wait
for the job to complete.

32. In the Job List, expand Local, and select the /runs/TRACE/StandPipeStream folder.

33. Press the View Output button ( ).
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This will open a pop-up menu of available files related to the job. Files are broken down 
into several types, as shown in the image below. Selecting any items in the Text Files 
menu will open the Output Viewer, described below.

The TRACE StandPipe job provides several files which can be opened by the File Viewer.
Some notable files include:

tracin - StandPipe.inp. The input file submitted to the TRACE executable.

trcout - StandPipe.out. The results of the calculation in ASCII form.

trcmsg - StandPipe.msg. Condensed output on the behavior of the numerical 
calculation and warning messages.

screen - StandPipe.screen. A collection of messages written to the console during the
run.

34. From the pop-up menu, select the trcout entry.
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The File Viewer will appear and display the contents of the file. The File Viewer was 
designed to allow very large text files on a remote Calculation Server to be viewed and 
searched over a relatively slow connection.

35. Press the Points of Interest ( ) button.

The Points of Interest search dialog will be displayed. The points of interest in the file 
are separated by type into expandable sections. Expanding each section will show the list
of points of interest of that type in the file and the line number on which is occurs.

For TRACE output files the points of interest include major edits, error messages, 
warning messages, and interactive commands sent from SNAP. 

36. Click on the Major Edits row to expand the list of major edits.

This will expand the Major Edits row to display the list of major edits in the file and 
will automatically select the first major edit in the list.
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Notice that the File Viewer is now positioned at the beginning of the first Major Edit. 
Each of the provided Points of Interest items will navigate to the point in the output 
where the item can be found.

37. Close the Points of Interest window.

38. Close the File Viewer
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Exercise 5. Restart Editing
This exercise describes how to build restart cases in a Job Stream. These steps build on the stand 
pipe model built in previous exercises. The StandPipe job will be used as a source for initial 
conditions. A null transient restart case and a transient restart case will be created. The transient 
case will resupply the valve, with the valve opening at time 250. The initial conditions for the 
resupplied valve will be retrieved from the null transient case on the server.

The following steps will guide you through the exercise.

1. Open SNAP_Exercises/StandPipe4.med, included with these exercises, and make the 
following modifications:

◦ Select StandPipeStream in the Navigator and make sure its Platform is set to 
“Local” and its Root Folder to “runs” (or the appropriate root folder used in place of
the runs directory).

◦ Select the TRACE step in StandPipeStream and make sure its Application is set to 
a valid TRACE application.

The property view will display the current Application in red if the property is 
invalid for the local configuration.

2. Right-click on the StandPipe4.med model node in the Navigator and select Manage 
Initial Conditions from the pop-up menu.

The Manage Initial Conditions dialog displayed below is opened. This dialog is used to 
retrieve, store, load, and discard sets of initial conditions retrieved from completed jobs.

3. Press the Store button.

A new row is created in the table, representing a set of initial conditions that have just 
been stored for later use. The contents of this initial conditions set were pulled from 
component values in the model. At any time in the future, the model's initial conditions 
can be reset to these values by selecting this row and then pressing the Load button.

4. Double-click in the Name column of the newly created unnamed row and change the 
name to "Original".
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The Name and Description of the row are the only means of indicating the contents of 
the initial conditions, so it is important that they accurately describe the row.

5. Press the Retrieve button.

The Initial Conditions dialog will appear, as displayed below. This dialog is used to 
retrieve initial conditions from completed calculations.

6. Select the A Submitted Run radio button.

7. Press the S to the right to select the job from which to retrieve initial conditions.

This will open the job selection dialog shown below.

8. Expand Local, then the runs folder, then the TRACE folder, and select the 
StandPipeStream folder.

9. Select StandPipe in the table to the right and press OK to close the dialog.

The previously submitted run is now the source of data from which initial conditions will 
be retrieved.

10. Press the Load Timesteps button.

Two Available Restart Times will become available.

11. Select the last restart time in the list: approximately,  Timestep 364 at 100.834 s.
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12. Press the OK button. 

This will retrieve the initial conditions at the last timestep and assign them to each 
component in the model. Notice the initial conditions of Pipe 1 displayed in the ASCII 
view have changed to reflect the data imported from the plot file.

13. Press the Store button.

As with storing the Original initial conditions, the initial conditions currently in the 
model will be represented by a new, unnamed row in the table.

14. Double-click in the Name column of the newly created unnamed set and change the 
name to "Steady State".

15. Select the Original initial conditions row and press the Load button.

The contents of the stored Original conditions will be loaded into the model. The Steady 
State contents will be used in a later step.

16. Press the OK button in the Manage Initial Conditions dialog to close the dialog.

With the initial conditions set, the following steps edit the model as a restart.

17. Create a new restart case in the Cases category.

18. Set the Component Name to Null Transient.

19. Select the Initial Conditions by pressing the S button in the editor.

A selection dialog will appear. This is used to select a set of initial conditions that the 
restart case will be based on. This has the effect that the selected initial conditions 
will be loaded automatically when editing a restart case in a virtual model (as shown 
in the next several steps).

20. Select Steady State and press the OK button.

21. Set the Editing Mode property of the new case to “Graphical”.

22. Begin editing the new Restart Case by pressing the E button for the Restart Model 
property.
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A virtual model will be created, where the restart changes are made. Notice the red dot in
the model node and the Restart Panel under it. The red dot is used to indicate models 
currently in Restart Editing mode and is used for all plug-ins that support restarts, while 
the panel is used to indicate that a restart case is being edited.

23. Select Model Options in the Navigator.

24. Change the Transient Calculation value to [1] Transient.

The following steps will illustrate how to perform manual ASCII edits to a restart case while 
performing a graphical edit. 

25. Select the Tools → Export to jEdit menu item.

26. Once jEdit opens, scroll to the bottom of the input model to the section with the Timestep
Data heading.

27. Change the tend value to 200.0.
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28. Save the input model to a local file location.

29. Right-click the Model Node in the Navigator and select the Import → Restart menu 
item.

30. Select the saved input model and press the Open button.

31. In the Restart Case panel, press the Save Case button ( ).

The changes made in the virtual model are imported as a complete restart case. The 
ASCII view of a Restart Case displays the generated input for that case.

Now that the null transient restart case is complete, the next several steps will build a transient 
calculation, where the valve is opened at 250.0 seconds automatically instead of relying on user 
interaction.

32. Create a second restart case 

33. Change the Component Name to Transient.

34. Set the Editing Mode to Graphical.

35. Begin editing the new Restart Case by pressing the E button for the Restart Model 
property.

36. Select Model Options in the Navigator.

37. Change the Transient Calculation value to [1] Transient.

38. Press the E to the right of the Timestep Data property to open the timestep table.

39. Change the End Time from 100 seconds to 400 seconds, then press OK.

40. Expand the Hydraulic Components [6] → Valves [1] node in the Navigator.

41. Select Valve 51.

42. Set the Valve Table Indep. Var. to Signal Variable 1 Problem Time.

43. Open the First Adjustment Table property editing dialog.

44. Press the Add button.

45. Set the table values to match the following:

No Unit Area Fraction

0.0 0.0

250.0 0.0

251.0 1.0
This table begins opening the valve at 250.0 seconds and finishes opening the valve a 
second later.

46. Right-click on the Model node in the Navigator.
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47. Click on the Select Restart Components menu item in the right-click pop-up menu.

This opens a dialog that allows selecting which components will be included in the 
restart case. Notice that Valve 51 is already included. When components are modified 
during a restart edit, they are automatically flagged for inclusion in a restart case.

48. Set the Available Categories drop-down list to Control Systems [8].

49. Select Problem Time 1 in the Available Components and press the Right Arrow button.

This selects the Problem Time signal variable which must be included in the restart case 
because the Valve table is referencing problem time.

50. Press the OK button.

51. In the Restart Case panel, press the Save Case button ( ).

Now that the restart cases are built, the next several steps will build a job stream that will 
execute.

52. Open the StandPipeStream view if it is not already open.

53. Expand StandPipeStream in the Navigator and add two new Model Nodes.

54. With TRACE model 2 selected, select the check box in the Restart Case property editor.

The property is now enabled, indicating that this model node represents a restart case.

55. Press the S button in the Restart Case property editor and select Null Transient in the 
selection dialog.

This model node now represents a specific restart, as indicated by its name changing to 
Restart Case 2. It will be used as the basis of a restart TRACE step in the job stream.

56. Press the OK button to select the restart case.

57. Set the Label value to null.

58. Repeat the above steps to set TRACE model 3 to use the Transient restart case, but set 
the Label to trans.

59. Create two new TRACE Stream Steps, as described in the previous exercise.
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60. Name the first new step “NullTransientStep”.

61. Drag the new NullTransientStep step from the Navigator into the 
“StandPipeStream View” to the right of the StandPipe step.

62. Drag the “Null Transient” model node from the Navigator into the 
“StandPipeStream View” just above the StandPipe step.

63. Using the Connection Tool, connect the input point of Null Transient to the tracin point
of NullTransientStep.

64. Connect the trctpr output of StandPipe to the trcrst input of NullTransientStep.

65. Set the third job step name to TransientStep and drag the TransientStep into the 
SandPipeStream view to the right of the NullTransientStep. 

66. Drag the “Transient” model node from the Navigator into the “StandPipeStream View” 
just above the NullTransientStep. 

67. Use the connect tool, as described above, to connect the input node of the Transient 
model node to the tracin input of the TransientStep.

68. Connect the trctpr output of the NullTransientStep to the trcrst input of the 
TransientStep.

Introduction to SNAP and Job Streams Page 39



The restart stream is now complete and should match the above image. When this stream 
is run, the StandPipe task will be run as before, using the base model. Once the 
StandPipe job is complete, the NullTransientStep task will run TRACE with the 
NullTransient restart case as its input and the TPR file created in the previous task as its
restart input. Finally the TransientStep task will run TRACE using the Transient restart 
case as its input.

69. Select the StandPipe step and set its Start Paused property to Off.

70. Select the NullTransientStep step and set its Interactive Step to On.

71. Select the TransientStep step and set its Interactive Step and Start Paused properties to
On.

Start Paused will not be available until Interactive Step is set to On.

The Transient restart case resupplies a hydraulic component but does include an Initial 
Condition set for defining the state conditions on the components. TRACE will report an 
error unless the state conditions of the resupplied component match the state conditions 
of the adjacent hydraulic components. The TRACE job steps supports retrieving state 
conditions for a restart job step from the preceding task.

72. Activate the Retrieve Initial Conditions property and select the Use Last Timestep 
radio button.

Note that the Time field allows retrieving the conditions from a particular Time as well.

73. Right-click StandPipeStream in the Navigator and select Submit Stream to Local from
the pop-up menu.

74. Press OK to confirm the stream submission.

The stream is submitted and Job Status will be displayed after the stream starts.

75. In Job Status, expand Local, then the runs folder, then the TRACE folder, and select the 
StandPipeStream folder.

The submitted stream steps will be displayed in the table to the right.
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76. Wait for the StandPipe task to complete, then for the TransientStep job to initialize and 
switch to the Paused status.

Note the distinction in terminology here. When creating a stream in the Model Editor, 
applications added to a stream are referred to as “steps”. When actually running the 
stream, these application runs in the stream are referred to as “jobs” or “tasks”.

77. Select TransientStep in the table.

78. Press the Job Console button ( ) in the Job List toolbar or double-click TransientStep 
in the table.

The job console for TransientStep will open in a new tab, as shown below. A job console 
will display the console output of a task and can be used to issue commands to 
interactive jobs, terminate the task, open local files, etc..

79. Press the Play button ( ) in the job console toolbar and wait for the task to complete.

80. Close Job Status.

81. Select File → Close All from the main menu.

82. Press the Discard All button.
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Exercise 6. Model/Component Diff Viewer
This exercise will instruct the user on how to use the Model/Component differencing utility. The 
diff tool compares the ASCII output of model components. Comparisons can be made between 
components, subsystems, or models.

1. Open the sample TRACE model “SNAP_Exercises/StandPipe_Resource.med” 
provided with these exercises .

2. Open the sample TRACE model “SNAP_Exercises/StandPipe_Comparison.med” also 
provided with these exercises.

3. Right-click on the model node for 
StandPipe_Resource.med and select
the Select Left Side to Compare menu
item.

4. Right-click on the model node for 
StandPipe_Comparison.med and
select the Compare to unnamed 
option.

The left column includes each of the
components which are contained in the
selected Left model
(StandPipe_Resource.med). The right
column includes the components in the
selected right model (StandPipe_Comparison.med). The comparison column includes 
the status of each of the component comparisons. In the case where a model component 
does not exist in the other model, the comparison column will display a Left/Right Side 
Only tag in green font. Components which have no differences will be displayed as No 
Differences. The components that are different will display Show Differences in red. 
Clicking Show Differences will open the component comparison window.

Introduction to SNAP and Job Streams Page 42



5. Left-click the Show Differences table cell for control block Subtract -4 (deltaP).

The component comparison window is displayed, as shown below. 

The Next Difference( ) and Previous Difference ( ) buttons provide a way of 
navigating through a series of differences. As each difference is encountered, the table at 
the bottom of the screen updates displaying the differences encountered at that line. The 
data is organized such that the left model ASCII is displayed above the right model 
ASCII. The characters in the lines which are different are shown in a red font.

6. Press the Next Difference button ( ) at the top of the component comparison dialog.

7. Visually identify the difference in the cbgain between the two components.

Note: Pressing the Export Diff Output button located at the top of the
component diff viewer will export the difference to an ASCII file.

8. Close the component diff viewer.

9. Select the Subtract -4 (deltaP) control block component in the left model column of the 
Multiple Component Comparison dialog.

10. Press the blue Move Up( ) button at the top of the dialog.

The Multiple Component Comparison window allows a user to modify the alignment of 
the compared components. The move up and move down buttons will take the selected 
component and swap it with the component in the selected direction. Once a component 
has been swapped to a new comparison position, a new diff is automatically generated 
for the compared components. This allows components of different types to be compared.

11. Left-click the Show Differences table cell for Subtract -4 (deltaP) vs Sum -5.

12. Visually identify the differences in the ASCII between the two components.

13. Close the component diff viewer and exit the Multiple Component Comparison dialog.

14. Switch to StandPipe_Resource.med by clicking on the corresponding accordion node.

15. Expand the Hydraulic Components category in the Navigator.

16. Expand the Pipes category and select Pipe 1.

17. Select Left Side to Compare from the pipe's right-click pop-up menu.
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18. With the same pipe selected, select Compare to Pipe 1 from the right-click pop-up menu.

Components which are compared to themselves keep a copy of the original component 
ASCII in the left hand side of the component comparison dialog. When one of the 
components attributes change, the comparison dialog will update to display the exact 
effect the modification had on the component ASCII. This allows a user to easily view 
what changes a modification will make to the original component ASCII.

19. Select Pipe 1 in the Navigator and open the editor associated with the Component 
Geometry attribute.

20. Change the Length of the first cell to “.2” ft and verify the component comparison dialog
updates to reflect the modification. 

21. Close the component comparison dialog and the geometry dialog.

22. Close the two models opened for this exercise.
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Exercise 7: 1D Hydraulic Renodalization
The purpose of this exercise is to introduce 1D hydraulic component renodalization in the 
TRACE plug-in. This will include observing the effects of nodalization changes on the rest of the
simulation model.

1. Open the included SNAP_Exercises/SingleChannel.med model.

2. Right-click on Pipe 2 in the Default View and select the Renodalization → Renodalize 
menu item.

Note: This opens the 1D hydraulic renodalization wizard. This wizard allows  the number
and relative sizes of the volumes to be changed in a 1D component. The first panel 
defines the new nodalization by splitting and merging volumes. The undo-redo buttons 
allow stepping backward through the incremental changes as needed. It is important to 
note that nodalization changes are incremental. That is, if cells are merged together and 
then split again, values on the removed edges will be lost.

The next steps in this exercise will halve the number of nodes where the fuel heat structure is 
connected. The cells will be merged together into a single volume then split into 15 equally sized
nodes. 

3. Select the Nodes tab in the dialog.
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4. In the table, select nodes 3 through 32.

Note: The selected nodes are highlighted teal in the drawing at the top of the dialog. 
Nodes may be selected either in the table or the drawing. Multiple nodes may be selected 
in either the table or the view using shift-click or control-click.

5. Press the Merge button.

The 8 selected cells have been merged together into a single cell. The data on the internal
edges of the selected regions has been lost, with the exception of irreversible loss. The 
flow loss values are merged into the down-stream edge by default. How the loss 
coefficients are handled may be defined using the Irreversible Loss Behavior drop-down 
list.

6. Select Axial Node “3” in the table and press the Split button

This opens the Split Cells dialog. This dialog defines how the selected cell or cells should
be split. The dialog shows the available fractions. Optionally, the Split Uniform button 
allows splitting the selected node into evenly spaced values.

7. Press the Add button until there are 15 cells.

Notice that the Fraction value is updated to preserve even spacing between the nodes. If 
the fractions do not sum to one when this dialog is closed, the values will be normalized 
before being applied to the target cell.

8. Press the OK button.

9. Press the Next button.

This renodalization dialog now shows how the nodalization changes will affect other 
components in the model. The top of the dialog shows a before and after rendering of the 
1D hydraulic component and the selected secondary component. The tree structure on the
left side lists all of the components affected by the renodalization. 

10. Select “Heat Structure 20” in the Secondary Components tree.
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Notice that the adjacent nodes have been merged together in modified version of the heat 
structure.

11. Expand “Heat Structure 20” in the Secondary Components tree and select “Slab/Rod 
Surface Temperature 6”.

Notice that the change summary on the lower right indicates that the target locations for 
signal variable 6 are changed by the update. Signal variables on volumes or heat 
structure cells are located at the cell center. Renodalization can change where along the 
axial length of a component the signal is obtained.

12. Select Heat Structure 20 in the Secondary Components tree.

13. Set the Consolidate Cells option to False.

Note: The consolidate cells option tells the system to merge together adjacent heat 
structure cells with identical left and right boundary condition data.

14. Press the OK button.

15. Press the Notes toggle button to hide the informational messages.
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The only message displayed is a warning message indicating that a signal variable 
source location has been modified. Notice the location values are displayed in red.

16. Press the Close button.

17. Right-click Pipe 10 in the view and select the Renodalization → Split menu item

18. Select internal edge 11 where the split should occur and press the OK button.

Pipe 10 has been split into two 10 cell pipes, with the outlet half being renumbered to 
pipe 80. Notice that heat structure 30 connects to both pipe 10 and pipe 80. An error 
would be reported if a signal variable has volume or edge location references that are on 
both sides of the pipe split location.

19. Select the Standard Stream view and unlock the view.

20. Select the restart model node.

21. Set the Restart Case property to “Split”.

Note: This restart case is a transient case that includes Pipe 80 in the iorder array. This is 
required to restart the renodalized model. The Short restart case would suffice if the only 
change was the Pipe 2 renodalization. Restart cases must be taken into consideration 
when performing renodalization, as existing restart cases will not be automatically 
updated.

22. Lock the view, press the Execute button, then wait for the calculation to complete.

23. Right-click the Plots step and view the “void_png” Image output file.

The next steps will work backwards to revert the nodalization to the previous state.
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24. Right-click Pipe 10 in the view and select the Renodalization → Select for Merge menu
item.

25. Right-click Pipe 80 in the view and select the Renodalization → Merge with Pipe 10 
menu item.

26. Press the OK button in the Merge Pipes dialog.
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The next steps will use the renodalization wizard to revert the nodalization of a 1D hydraulic 
component to match the values entered in a different model. This is done by selecting a model as 
a “reference model” and then selecting the source of the geometry from the renodalization dialog.

27. Select the File → Save As menu item and save the file to a new file location. 

28. Right-click the Model Node in the Navigator and select the Load Reference Model 
menu item.

29. Select the SNAP_Exercises/SingleChannel.med model included with these exercises 
and press the Open button.

30. Right-click Pipe 2 in the view and select the Renodalization → Renodalize menu item.

Notice that the revert button is enabled.

31. Press the Revert button.

32. Select Pipe 2 in the selection dialog and press the OK button.

33. Select “all cell and junction data” from the confirmation dialog and press the OK 
button.

34. Press the Next button.

35. Press the OK button.
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36. Change the restart model node in the Standard Stream back to the “Short” restart case.

37. Submit the Standard Stream model again and wait for the jobs to complete.

38. View the “void_png” Image output from the plot exercise.

This completes the 1D hydraulic renodalization exercise.
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Exercise 8. Working with View Templates
This exercise is designed to familiarize the user with importing existing models and View 
Templates. View Templates provide a means of saving a layout of a view that may then be 
applied to a similar model.

In this exercise the user will use a sample View Template to lay out an imported model.

1. Select the “File → Import → TRACE” main menu item.

2. Set the File Type option on the right to “ASCII”.

3. Select SNAP_Exercises/standpipe_viewtemplate.inp, included with these exercises.

4. At the Create Views prompt, uncheck all check-boxes and press the OK button.

The model will be imported without views.

5. Create a new empty View by right-clicking on the Views node in the Navigator and 
selecting the New menu item. 

This should create and open a new View with the name "View 1" and display its 
properties in the Main Property View.

6. Right-click anywhere inside the newly created View.

This will open the 2D View pop-up menu with items such as Organize and Zoom.

7. Select "Tools→Import View Template" in the pop-up. 

8. Select SNAP_Exercises/standpipe.mvt, included with these exercises, and press Open. 

This will apply the
template to the view, which
should now appear as
shown here.

Note: To export a View Template
of an existing view, use the "Tools
→ Export View Template" item
off the right-click pop-up menu in
the View.
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Exercise 9. Resource Bundle Import/Export
The TRACE plug-in provides a series of features which facilitate the editing of input models. 
This exercise will familiarize the user with using the Resource Bundle feature to quickly modify 
a set of components outside of the Model Editor as ASCII and re-import the model without 
losing model data such as views, documentation, or SNAP variables.

1. Select File → Open from the Model Editor's main menu.

2. Select the TRACE model SNAP_Exercises\StandPipe_Resource.med, included with 
these exercises.

3. Export the sample model as a resource bundle by selecting File → Export → ASCII Full
from the main menu.

4. Select the Include Resource Map check-box in the Export File selector. 

Note that the TRACE plug-in will prompt the user to save the current model before the 
resource export completes if the model has not yet been saved.

5. Export the resource model as: “standpipe_resources.inp”

6. Using jEdit, locate and open the exported resource model.

Notice that the file includes a section at the top for a numerics map. This allows SNAP 
variables to be reconstituted from ASCII resource import.
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7. Locate the Timestep Data section located at the end of the input deck.

8. Change the end time (tend) to “1200.0” and save the model.

9. Close jEdit.

10. In the model editor select File → Import → TRACE from the main menu and choose 
the file “standpipe_resources.inp” exported previously.

11. Press the Yes option when the plug-in asks whether to import the resource file.

Note: The resource import allows the user to specify which resources to include from the 
resource file. This includes views, SNAP variables, and model documentation.

12. Verify that each of the available options are selected in the dialog and press the OK 
button.

13. Right-click the Views category and select Open Views from the pop-up menu.

To speed the resource import process, imported 2D Views are not automatically opened.

14. Select the Model Options node in the Navigator.

15. Locate the Timestep Data property and open the associated editor.

16. Verify the End Time was updated to 1200.0 seconds and close the dialog.

17. Select File → Close All from the main menu.

18. Press the Discard All button.
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Exercise 10. 2D Drawing Features
The goal of this exercise is to demonstrate some of the features used to create larger and more 
complex nodalization views with the Model Editor. This process begins with Layers, to illustrate 
some of the ways layers can be used to organize complex views. Afterward, the drawing 
capabilities of the Polygon bean are used to complete the illustration of the broken loop.

1. Open the file "SNAP_Exercises/TraceTypPWR.med" included with this exercise.

2. Open the Noding Diagram view by right-clicking the view's node in the Navigator and 
selecting the Open item.

This model opens with a single 2D View visible: a free form "nodalization view" of the 
full plant model. In appearance, it is similar to the full plant view in the Typical PWR 
animation mask. There are, however, a few significant differences that will be described 
later.

3. Open the Layer Manager by pressing the Layer Manager button ( ) on the view 
toolbar.
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Note: Layers provide a means of organizing the elements in a view. They can be locked 
and hidden independently. Locking a layer prevents elements from being clicked on or 
selected while the view is unlocked. Hiding a layer hides the elements in the layer from 
view.

The Layer Manager is used to create, hide, and lock layers as well as to set the current 
layer. All elements added to a View are added to the current layer.

Layers are listed in alphabetical order following the Default layer, which appears first. 
The Default layer is always available and contains all of the elements in the view that  
have not been moved to another layer.

4. Click the Hide/Show button ( ) to the left of Steam Generators layer.

Notice that the secondary side components appear in the view when this layer is made 
visible. Hiding components in a layer is conceptual (primary vs. secondary side) and 
practical. Working with stacks of elements (polygons in this case) is easier when the 
elements below or above can be hidden. In this case, the secondary side of the steam 
generators can be hidden to make working with the u-tubes easier, or vice-versa.

Layers may also be locked, which prevents elements in that layer from being selected. 
Layers may be locked or unlocked by pressing the Lock ( ) button or the Unlock button 
( ).

5. Select the 1.5 Extra Vessel layer by left-clicking on the layer name in the Layer 
Manager.

6. Remove the layer by pressing the Remove button ( ) at the top of the dialog.
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In this case a window is displayed asking what to do with the contents of the layer 
being removed. The options are to either move the contents into another layer or to 
remove the elements. A drop-down to the right has the list of layers the elements can be 
moved into. The initial choice is to move the elements into the Default layer.

7. Expand the Drop-down list and select 1. Vessel from the list of available target layers.

8. Press OK to move the contents of the Extra Vessel layer into the Vessel layer.

To the right of each layer name in the Layer Manager is the number of elements in that 
layer. Notice that the Vessel layer had 27 elements and now has 75.

9. Create a new layer by pressing the New Layer button ( ) at the top of the dialog.

This will be the layer for the new parts created for this exercise, but first, it will need an
appropriate name.

10. Rename the new layer to "New Parts" by double-clicking on the name Layer 1 and 
entering the new name.

That gives it an appropriate name, but unless it is the Current layer the new parts won't
be automatically added to it.

11. Set the Vessel layer as the current layer by pressing the radio button to the left of its 
Hide/Show button.

Notice that Vessel now appears as the current layer displayed in
the Layer Selector on the view toolbar to the right of the Layer
Manager button. The Layer Selector can be used to set the
Current layer directly, without opening the Layer Manager.

12. Set the newly created New Parts as the current layer by left-clicking on the Layer 
Selector and selecting “New Parts” from the list.

Also note that the list of layers also included a New entry. This is a quick way to create 
a new layer and set it as the Current layer.

Note: Additional information about Layers and the Layer Manager is available in the 
SNAP User's Manual by pressing the Help button at the bottom of the Layer Manager 
window.

That completes the Layers section. Next, we'll look at the Associated Component feature. Then, 
we'll create a few polygon beans to replace those that are missing in the view.

13. Zoom in on the broken loop (left) steam generator using either Ctrl + Mouse Wheel or 
the Zoom Tool.
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14. Left-click on the white u-tubes labeled 204. 

This will select the polygon that was added to
represent pipe 204 in the view.

15. In the Property View select the check-box next
to the Associated Component property

16. Press the Select button in the Associated
Component property.

17. Select Pipe 204 and press the OK button.

18. Lock the view by pressing the Lock button (
) in the view toolbar.

19. Left-click the white pipe in the view that was
previously selected.

Nothing in the view will change to indicate where it was clicked, however, the main 
Properties View will show the properties of Pipe 204 (bsgtbs) and the Navigator will 
scroll to and select Pipe 204.

20. Unlock the view by pressing the Unlock button ( ) in the top left-hand corner of the 
view.

Now that we see how drawing elements can be associated with components in the model, lets 
take a look at how to create some of the shapes required to build a detailed nodalization view.

21. Zoom out and examine the difference between the "Broken Loop" on the left and the 
"Intact Loop" on the right.

Notice that the broken loop accumulator (290) does not appear to have any water in it 
while the intact loop accumulator (190) does. This is a purely aesthetic difference, as 
the nodalization view does not directly reflect the conditions of the accumulator. 
However, it does make the drawing more distinct.

22. Zoom in on the Broken Loop accumulator 290.

23. Activate the Polygon insertion tool ( ) by selecting it from the Insert Menu to the 
right of the Connection Tool on the view toolbar.

24. Start the accumulator polygon by clicking on the left side of the accumulator about even
with junction 292, then working counter-clock wise around the shape.

Follow the points in the given diagram. If you click in the
wrong place, right-click to remove the last point.

25. Left-click at each corner of the shape to add points.

Notice that each point will try to form a straight line from
the previous point.

26. Double-click on the first point to finish and close the
polygon as shown.
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You'll notice that the existing accumulator's boundaries are slightly thicker than the 
new polygon. We'll fix that first so that the lines will be easier to match up.

27. In the Properties View, set the Outline Thickness property to “2”.

28. Set the Polygon's Fill Color property to a light blue, “121,184,246”.

Now, it's time to round off the bottom to match the accumulator.

29. Right-click the bottom edge of the newly created polygon.

This will display the Polygon pop-up menu. At the bottom of this menu are several items
specific to the Polygon.

30. Select the Curve Segment item from the pop-up menu.

This will change the straight segment into a curved segment.
Curved segments have a start and end point (like straight
segments) but they also have two control points. These control
points are used to control the curve of the segment.

Note: The Curve Segment item will only be enabled when
right-clicking exactly on the line segment. If you miss, just click
away to close the pop-up menu and try again.

31. Drag the left control point straight down from the bottom left point to the location 
shown.

The control point locations don't have to be perfect. They can always
be corrected later if the shape doesn't look quite right.

32. Drag the right control point straight down even with the left.

This will add a nice rounded shape to the bottom of the accumulator.

33. Use the arrow keys to move the new polygon directly on top of the
original.

The new polygon gives a sufficient hint that there is liquid in the
accumulator, but it could be better. It more resembles a pill than an
accumulator. It would look better without the black line between the
new and original polygons and maybe a wavy top to the liquid.

34. Right-click on the center of the top segment and select the Add Point item to add a 
point to the top of the new polygon.

To get a good wavy look the line will need a center point for the two pairs of curves. But
first, the top segment lines need to be hidden.

35. Right-click on each of the two top segments and select Curve Segment to curve the 
new segments.

36. Drag the left control point for each segment down and to the right.

37. Drag the right control point for each segment up and to the left.
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That takes care of the wavy appearance of the top of the liquid. More ripples can be 
added by adding more points.

38. Right-click on each of the top segments and select Hide Segment to remove the outline 
from the new segments.

In this particular example the accumulator number (290) has been hidden by the water. 
As a final step, we'll pull that to the foreground.

39. Right-click the accumulator 290 text annotation and select the To Front item from the 
pop-up menu.

That completes the Intact Loop accumulator.
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Exercise 11. Using AptPlot and the ACS Plug-in
This exercise is designed to familiarize the analyst with the basic functionality of AptPlot and the
ACS plug-in. A TRACE plot-file will serve as a source of data for several graphs on a plot. In 
addition, some introductory graph and data set formatting will be performed.

The following steps will guide the user through the exercise.

1. Open AptPlot. From the Windows Start menu, select All Programs → Plotting Tools → 
AptPlot.

This will open AptPlot with a new plot, as shown below. From here, data will be added to
the plot from a TRACE plot file.

First, a quick rundown of the window. The white area is the plot. Anything appearing
within  this  “canvas” is  part  of  the  plot  and will  appear  in  print-outs  and exported
images. The rectangle within the plot is a graph. The data itself is represented by Data
Sets: linked columns of data contained within a graph. From the bottom up: data sets
form lines on the graph, graphs create a window into their data, and plots are the root
container for everything. 

The new plot  in the window contains a single graph without  any data sets.  The first
several steps of this exercise will add a data set to the graph by reading values from a
TRACE plot file.

2. From the AptPlot main menu, select File → Read → TRACE data.... 

A file selection window is displayed.
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3. In the file dialog, select Next Available for the File Index and XTV for the File Type.

The file type tells AptPlot how to attempt to read the selected file. Most TRACE plot files
will use XTV, even if the file has been demultiplexed. A demultiplexed file is a version of
the plot file reorganized for more efficient plotting. Demultiplexing is explained in detail
in the AptPlot documentation.

As for the file index: each code type supported by the ACS plug-in allows opening up to
30 plot files at any given time. File index specifies which of those slots is assigned to the
selected file. With Next, the file is assigned to the next unused plot index.

4. In the file dialog, navigate to the SNAP_Exercises folder provided with this exercise.

5. Select the file StandPipe.xtv.

6. Press the Open button.

A channel selection window will appear, similar to the image below, which will be used
to read the channel data into the plot.

7. Select pipe-2 in the list of categories of the left.
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The list of channels will change to those associated with the pipe-2 component.

8. Type “pn-*” (sans quotes) into the Filter field and press the Enter key.

The list  of  channels  will  be filtered  to  only those channels  whose names begin  with
“pn-”. The  * character will  match any string of letters (including none).  “pn-2*1*”
would match any channel name that starts with “pn-2” and ends with “1”.

9. Select pn-2A01 from the list of data channels and press the Plot button.

The channel data will be plotted in the graph, as shown below. Notice that the graph's
displayed axis values change to fit the data. Each graph has a set of World Coordinates
that define which the range of values it displays. To illustrate, zooming out on a graph
widens the world coordinate window.

Unfortunately,  this graph's numeric axis labels reach to the edge of the plot with the
default formatting. While it is not currently visible, a vertical unit label “Pressure (Pa)”
has been added to the Y axis: the long axis labels have pushed it off the plot. The next
several steps will re-size the graph until this label is visible.

10. Close the channel dialog.

11. Double-click and hold on the upper-left corner of the graph, where the small black square 
is placed.

This  will  initiate  a  graph  re-size  operation,  indicated  by  the  red  “rubber-bands”
displayed on the plot. By moving the mouse around, the rubber-bands indicate the new
bounds of the plot. Clicking once will place the corner in its new location and re-size the
graph.

12. Make the graph a little smaller by placing the corner slightly to the right of its original 
location.

13. Repeat the previous two steps until the “Pressure (Pa)” label is completely visible.
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The current graph displays large values in a relatively narrow range. Further into the
exercise,  a channel will  be plotted with very small  values.  If the new data is  plotted
alongside  the  current  data,  the  graph will  appear  as  two straight  lines  with  a wide
margin between them. To avoid this, the new data will be placed on a second graph.

14. From the main-menu, select Plot → Graph appearance....

The Graph Appearance window is displayed. The top of the Graph Appearance dialog is
a graph list. Selecting a graph in the list determines which graph's appearance is being
edited below. This type of graph list is used frequently throughout AptPlot, and each one
provides identical functionality. This particular dialog was opened specifically to create
a new graph from the graph list. In practice, any AptPlot dialog with a graph list could
have been used.

15. Right-click anywhere within the graph-list and select Create new from the resulting 
pop-up menu. 

A new graph is created. The plot should look similar to the one below.  The new graph
overlaps a significant portion of the original graph. This could be fixed by moving the
graph corners around, but this would ignore several options AptPlot makes available for
quickly laying out plots.
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16. From the main-menu, select Edit → Arrange graphs....

The Arrange Graphs window will be shown. With this dialog, graphs can be arranged in
a  grid  of  any  dimensions,  automatically  assigning  each  the  same  size,  vertical  and
horizontal  spacing,  and overall  margin  from the  edges  of  the  plot.  Additionally,  the
dialog can create and remove graphs as needed to fill the grid.

17. Select both graphs in the list. To select both graphs, select one, press and hold the Shift 
key, then select the other.

Both graphs must be selected to indicate they are the graphs being arranged. If only one
graph is selected, AptPlot would create a third graph, as the parameters entered in the
next step tell AptPlot to create a graph grid with two rows in one column.
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18. Set the following properties in the Arrange Graph window to the indicated values:

Matrix Columns: 1
Rows: 2

Page offsets Top: 0.2
Bottom: 0.2
Left: 0.2
Right: 0.2

Spacing Hgap/width: 0.2
Vgap/height: 0.4

Note: The offsets and spacing above are specified in View Coordinates. A quick 
explanation: AptPlot creates a coordinate space for graphs that is based on ratios. The 
shortest side of the plot is 1 viewpoint long; the longer side's length is a ratio to the 
shorter side. This coordinate space is used to retain relative dimensions regardless of 
how the plot dimensions are changed. For example, if a user doubles the width of a 
plot, a square graph remains a square instead of transforming into a rectangle. If both 
dimensions of that same plot are doubled, the graph expands to correctly fill the 
space, retaining its original relative dimensions within the plot. The viewpoint 
coordinate system is the backbone of AptPlot's ability to create plots of any resolution
that still appear identical to what's displayed on screen.

19. Press the OK button.

The  Arrange  Graphs window  disappears  and  the  graphs  are  rearranged.  The  next
several steps will add data to the second graph.

20. From the main menu, select Edit → Edit plug-in data → TRACE data....

The channel dialog will reappear. Once a plot file has been opened, its data can always
be accessed from the Edit menu (unless another file is opened in its file index).

21. Select rovn-2A01 in the channel list.

Remember that a channel filter can prune the list.

22. Select “(+) G1” from the Graph drop-down at the bottom of the window. 
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This selects the graph into which the data will be read. 

23. Press Plot to display the channel data, then close the dialog.

At this point, the plot should have two graphs with data, axis labels, and legends. Notice
that the second graph's legend is placed on the first graph. The next several steps will
move the legend to a better location.

24. Click once anywhere on the second graph to select it.

Many operations in AptPlot depend on the graph selection to determine which graph is
affected. Moving the legend in the next step is one of them.

25. Press Ctrl+L.

AptPlot  will  enter  “Move Legend” mode in  the  plot.  This  is  visually  indicated  by a
change in the mouse cursor.

26. Click and hold on the legend containing the entry rovn-2A01.

This will begin an operation to move the legend, indicated by a shaded preview of the
new location. Moving the mouse will move the preview indicator. Clicking once will set
the legend in its new location. The move can be canceled by pressing the escape key or
right-clicking.

27. Reposition the preview indicator to a location on the right-side of the second graph, then 
click once.

The legend will be placed in the new location. The plot should look similar to the image
below.
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28. Press the Escape key or right-click.

While  this  exercise  moved  the  legend  with  the  mouse,  its  coordinates  can  also  be
explicitly specified by editing the graph's appearance.

29. Repeat the last five steps to reposition the first graph's legend. When complete, the plot 
should resemble the following:

The final steps of this exercise will modify the appearance of the data set in the second
graph.

30. Double-click anywhere within the second graph.

The Set Appearance window shown below is displayed. Double-clicking within a graph
opens the Set Appearance dialog for that graph's data sets. This dialog could have also
been displayed by selecting “Plot → Set appearance...” from the main menu.

31. Make sure the data set is selected in the set-list the top of the dialog.
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Like graph lists, set lists are used throughout AptPlot to select data sets. Also like graph
lists, right-clicking on a set list will open a pop-up menu of set-related operations. Unlike
how a graph list displays all graphs in the plot, the contents of a set list will always be
the sets of the currently selected graph or those of the graph selected in a nearby list.

32. In the Main tab, set Line properties Color to Red. 

33. In the Main tab, set the Symbol Properties Type to Circle. 

34. In the Symbols tab, set the Extra property Symbol Skip to 35. 

35. Press the OK button.

The data set will be adjusted with the new formatting. Notice how the set is now painted
as a red line with a circle around every 35th point. The plot should look similar to the
image below.
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36. From the main menu, select File → Save.

A file dialog is displayed requesting where to save the plot.

37. Navigate to the SNAP_Exercises folder in the directory provided with this exercise and 
save the file as “UsingAptPlot.apf”.

38. Close AptPlot.
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